Distance Sensor not recognized

We had this distance sensor quite awhile & it was working on the Clawbot. We just built the new Armbot with sensors & tried to update the firmware. Everything was recognized & updated except the Distance Sensor. It said it was “Not Connected”. This was the most recent firmware. We tried changing the cable with a known working cable & also changed the port with a known working port. When repowered & ran the firmware updater again the result was the same…“Not Connected”. Obviously the sensor is not working! Due to it being out of warranty & the cost not negligible we decided to attempt opening it to see if we could repair it in house. Does anyone know how to open it without damage? Also, any advice on where to find info to repair it? I’m knowledgeable in electronics but have not worked with no spec sheets. Any suggestions?

Hi Grandpa3,

We’re sorry that you have encountered this issue. To help resolve this problem, please remove all other motors and sensors from your Robot Brain, then connect the Distance Sensor to Port 1 on the Robot Brain. Then connect the Robot Brain to your computer and run the Firmware Update Utility to update/re-install the sensor firmware.

When there is only one device plugged into the Robot Brain and it is on Port 1, the Robot Brain will try to force download the sensor firmware into that device.

If this does not work or if you have additional questions, then please contact VEX Technical Support at [email protected] or by calling +1-903-453-0802 so we can help resolve this issue.


  • Art

Hi Art,

Thank you for your speedy reply. Unfortunately, your suggestion did not correct the problem but you taught this old dog a new trick to try in the future. I disconnected every device from the Robot Brain, then connected the Distance Sensor to Port 1, connected the brain to the computer, powered the brain on, & ran the Firmware Update Utility. Again it said the Distance Sensor was “Not Connected”. The Device Info in Settings also reported Port 1 was Empty. Just to be sure I swapped out the Distance Sensor with a Color Sensor, repowered, & restarted the Update Utility. The Utility recognized the Color Sensor on Port 1 & pronounced it “Up to Date”. Therefore the Distance Sensor is defective. I will have to wait until next week to call support unless someone else suggests another option. BTW, this sensor has incurred no physical damage to it & appears in pristine condition.

Best regards,