distance sensor program issue

I got a brand new super kit recently. Followed the manual to connection all sensors to the designated ports in the manual, and updated all sensors and brains to the current firmware. Then I followed the online curriculum to program and all sensors run pretty well, except of the distance sensor. My program is in the attached picture.

The robot motor never start when I first run the program. Then I added “wait 2 seconds” as shown in the picture, the robot can run 2 seconds. After deleting this sentence, the robot never start again. I tried to put the robot at different open spaces with no objects at all. Still no luck. I also tried two different values of distance, such as 500, 100, but it does not help.

I suspect the distance sensor may be bad. Then I followed other forum member’s suggestion to check the device info on the brain screen. I tried to move some objects around the robot. Looks like the distance sensor can detect the objects and the screen shows “no object”, “485 mm”, “152mm” and so on. The detected distance values are generally correct.

Any suggestions?