Distance Sensors 'No Object Detected' on some Brains; working on others

I have a class with 10 Robots. Two of the Robots are showing ‘No Object Detected’ when Distance Sensors are plugged in, but these same Distance Sensors are working on other Brains.

I have tried switching on while pressing both arrows and reinstalling the latest VEX OS, but still the problem persists.

These Brains are showing the Distance Sensors as available (and up to date, according to VEX OS Utility), but will show no readings on the LCD - only ‘No Object Detected’.

Are there any other steps I can take, or is this a problem with the Brains? (Which is strange as everything else seems to be working…) Is there something specific to Distance Sensors that I’m missing?

Thanks :slight_smile:

Have you tried changing which port the sensor is plugged into on the robots that aren’t working? I don’t know why this would matter but I’m curious to know if it does make a difference on these robots. Change them to a port at least 3 spaces away from the original to check. (Ports are connected internally in groups of 3, 1-3,4-6, etc)

Also,you might try updating the firmware on the sensor individually. Unplug all the other sensors. Plug the ultrasonic sensor into port 1 and then update that sensor only. To do that, open VEX os Utility and click on Refresh. Then right click on the pic of the sensor and choose update.

Please report back how this gets resolved.


1 Like