Does PROS actually run on Windows?

I have been trying to install PROS on Win 10 for a few days with zero success. This is the error when I build:

c:\Projects\VexVRC\PROS\TestRos>pros make
Creating cold package with libc,libm,libpros,okapilib Error: Failed to build
/bin/sh: line 1: arm-none-eabi-g++: command not found
make: *** [ bin/cold.package.elf] Error 127

The same error when doing a make from the command line or through Atom. I tried with and without Windows Subsystem for Linux installed, same error. I found this bug report:

and added my comment, but that doesn’t look to have any constructive response (though it is 5 months old and for a previous version of the software).

So my question is: has anyone actually installed PROS 3.1.4 or on a fresh (never seen PROS before) Windows 10 computer successfully? If so, any help getting it to work?


Have you tried the list of fixes for known issues in this post?


Take a look at this part spcifically


Yeah, that fixed it. I saw it earlier and thought it only applied to the version from that small time frame. But adding the path to g++ to the PATH variable worked. Thanks