Does Vex VR work on Macs?

I have a student who claims he can’t get VEX VR website to work. He’s using a Mac Airbook. Is there any known issues using Vex VR on Macs?

Mac doesn’t make chromebooks… the title is kind of misleading.


A confusing title but VEX VR ( should work on both Chromebooks and Macs.

What isn’t working in particular? If it won’t load: what browser (and version of it) are they using?

1 Like

Have the students use the feedback tool (top right corner) and let us know what the issue is - that way we can collect diagnostic info to troubleshoot the problem.

VR works on all platforms - Mac, Windows, Chromebooks, iPad, Android, Amazon Fire…


Sounds like said student is trying to get out of work. Have them send you a screenshot of the issue there having then you should be able to tell if there lying or not.

I have a chromebook and it works perfectly fine for me.

My mistake, the student has a school issued Chromebook but he keeps having connection issues.

That’s very possible, but I need to nail down any possible issues before going down that route. I don’t have a Mac so I couldn’t test it

1 Like

Thanks, sounds like it’s a user end problem

1 Like

the site does not load in my MACBOOK AIR. i’ve tried SAFARI and CHROME and it doesn’t load. just gives me a 500 INTERNAL something error. my son can’t access it with a MAC, and we’ve tried it on 3 different MACs. he only gets to use it using a Windows machine. has anyone here recently loaded the said site using a MAC running Catalina?

Yes it works fine on macos.

I have a mac and it works fine. VEX VR is a browser website and does not require any installation whatsoever. Maybe connection problems??? This is the link

I have a MacBook Pro and it runs perfectly on it. It worked fine when I had Catalina, and it continues to work now that I am running the Big Sur Beta

I have a 2019 MacBook Pro running Catalina and it works fine for me. Perhaps your internet connection is unstable?

We are encountering same error, even if i’m using windows now! Anyone can help? Thanks in advance.

Location: Philippines


If you clear your cache and cookies then restart the browser, are you still seeing the issue? I’m guessing so if you are seeing this on multiple machines but it is worth a try.

I think its not the browser problem. Im using vpn and it works fine! May i know any solution without using vpn? Thanks a lot :tired_face:

Your IP address is probably blacklisted. I wouldn’t be surprised if VEX is using Cloudflare or another similar service — they tend to block a lot of IP ranges to help mitigate denial-of-service attacks.

Check your IP address on a blacklist check tool — it might corroborate this theory.

I would first try contacting VEX to ask if they can somehow whitelist your IP address. (Find your IP address here)

If that doesn’t work, you can explore options to get a new IP address. But that can be an irritating process even for people familiar with networking.

1 Like

We’re logging 500 errors on the VR server side to track down the root cause of the issue. We’ve done a few things to fix it so far, so it should hopefully be resolved - but we’re continuing to track down these issues as we see them.