Double red lights on joystick controller

There are double red lights on my joystick controller. It stays that way when tethered to my robot, which is on and fully charged. We tried charging the remote using both the tether and the charging cable it does not work when not connected to the robot. It shows double red when tethered and shows no signs of life when you try to turn it on and it is not tethered. We have driver control of the robot when it is tethered. We have tried swapping out a new battery. Please help us find out what is wrong.

The radio may be broken, or the radio slot is broken. That is my theory.

Are you running the latest firmware on the controller? Also, are the radio modules pushed in all the way? They are sometimes quite hard to engage properly.
However, if the controller won’t event turn on then there would appear to be an issue with either the batteries you have or the controller itself. Do you have a known good battery you can try in the controller (i.e. one that is working in a different controller)?