Downloading issues(PROS V5)

When i download any program, no matter what i change the program, my Op.control program also remain the same. Its ports are always assigned at 1 and 2 even though my program declare the ports as 1 and 8. Did i modify the wrong program. My program is in the Src files Op.control program.

If you launch the terminal, you’ll see when the program was compiled. Does it look right?

I have had a similar issue but it was solved when we corrected the code and fixed it. Make sure that the console isn’t showing anything weird and that NOTHING is red underlined in your code. This will prevent the download and when you run the code it will run the default drive code for the Vex V5, which would explain the ports being activated differently then you call for.

Make sure you compile (build) the project before uploading. If you just hit upload, it will just upload the last successfully compiled version.
The quick action button automates the process for you, it builds and then uploads.
As others have said, make sure it actually compiles successfully and you see no errors,