Driver control not working

Hello, I have been teaching Vex IQ for several years now and this year got a EDR class to teach as well… Has been going fairly well so far, but have now run into an issue of getting the controllers to control the robots again. I had them write and run several basic programs through RobotC which all worked fine. Now I am trying to get the robots to be drivable by the controller again. I download the sample file tank control to the robots and nothing happens. All motors/sensors are set correct, all firmware I tried to re update. Program seems to download to the robot fine, but whether I have the controller connected to the robot through the usb a-to-a cable or wireless the robot does not respond at all. I get all the correct lights on the cortex and the controller that they are connected to each other. What am I missing?

With IQ basic driver control always stays loaded on the robot. That doesn’t seem to be the case with EDR. Is there a way to always keep it loaded on? At competitions it seems the robots run their programs than start driving… is it all just part of the same program?

Thanks for the help, I trying to get caught up to the differences between IQ and EDR.


Yes, in VEX EDR, for competitions you’ll use the Competition template, which you can find in File > New… > Competition template. Then, you’ll want to put the joystick code within an infinite while loop (

while (true)

). Another thing to check in ROBOT: Go to Robot > VEX Cortex Communication Mode and make sure it’s set to VEXnet or USB.

The robot will run whatever you last downloaded to it - so if you want driver control code, you’ll need to include that in the program on the robot. That being said, it’s easy enough to create a quick test program and then download the original program back on to the robot.

It sounds like this may be a code issue - can you copy/paste the code here so I can take a look?

Hi Evan, Thanks it ended up being the communication mode was only set to vexnet.