Driver Interface Controller LEDs Not Illuminating


#1

Helping to set up a tournament field last weekend where the Driver Interface LEDs were not illuminating, but the Match Controller LEDs were both green. We would expect the **Disable **LED to be illuminated.

There were 3 fields at this tournament - only one field had this problem.

These steps did not resolve it:
Unplug USB from Match Controller
Reboot Laptop
Plug USB back into Match Controller
Both Match Controller LEDs become green
Driver Controller LEDs are not illuminating

  • For either Driver Controller connected to the Match Controller

Tried different Match Controllers - same results
Tried different Driver Controllers - same results
Tried different network cables - same results
Tried different laptop - same results

Since the Match Controller’s LEDs were both coming up green, decided to start up the Tournament Software, but that didn’t make any difference.

We overcame this issue by just using a manual competition switch - this was for the Skills field.

I’m suspecting this is a USB type issue - but troubleshooting information is limited. The forum post “Field Control - a technical analysis” is helpful, but I do not find where/how the Driver Controller will not have any LEDs illuminated if the Match Controller’s LEDs are green.

Is there a reason the Match Controller would show both LEDs green, but not illuminate any of the LEDs on the Driver Interface Controller?

Are there other troubleshooting steps that can be done?

Has anyone created an interface test device - maybe similar to a PoE (Power over Ethernet) test?


#2

Normally, restarting the tournament software will clear this issue. Since you replaced the Match and Driver Controllers, Cables, and the Laptop - that covers about everything.

Can you repeat this issue using the same components?


#3

We’ll have access to the components this evening and see if we can recreate the issue. I’ll post an update with those results - could be tomorrow 3/4/15 when I can update.

I’m also bringing my Network cable tester to see even though we tried several Ethernet cables, maybe they all had some odd impairment - not likely, but I’ll check.


#4

If you can duplicate the issue, see if you can also get a different system working. If you get that done, try swapping only 1 component from the system not working with the system that is working. Note, you should shut the software down (OFF) each time before the swap and then start it again after the swap.

If the working system stops working after a swap, the component you swapped may have issues. You can do this several times to see if the problem always exists when using that component.


#5

Due to a longer than expected meeting the troubleshooting was not performed. The field hardware is still packed away - and won’t be needed for several months. If there are no troubleshooting steps available other than just swapping out the various hardware items - this thread can be closed.

Was hoping there was a known state where Match Controller LEDs would have shown green and Driver Interface LEDs remained off. That doesn’t seem to be the case.


#6

Sorry to hear you were not able to due any further troubling shooting. My best guess at this time is that you would not have been able to duplicate the issue. I have always seen that just re-starting the software corrects the issue unless the USB Port on the PC got confused. If that happened, the PC would also have been required to be turned OFF and then re-started to correct the issue.

Be sure to give yourself some time to check out your systems before they are needed again. If you do find an issue at that time, please let us know as we would like to get the failed parts back for further investigating.

If we do find another solution to the issue you have described, we will let you know. Glad you did realize the quick work-around by using the VEXnet Competition Switch to control the Field.


#7

I had the same problem with my driver interface, what i figured out is that you need to install the driver for the cp210x chip. Then your computer will recognize that the match controller is plugged in and vex tournament manager will give you a pop up to test it and set it to a field.

[Edit] I know that this is a really old thread but just wanted to help anyone with the same problem and found this thread like i did.


#8

Whoa - 4 years later! Thanks for sharing :smile: