Driver motors reversed after firmware update - me too

I couldn’t find a way to add this to the existing thread, but I have exactly the same issue: clawbot assembled out of the box worked fine, after a firmware update all the motors are reversed. Firmware update utility shows everything to be up-to-date. (Brain is 1.02, controller is 1.01).

There is a drive mode configuration menu, it shows:

Control: 2 Joystick
Drive: Normal
Motor 4: Reverse
Motor 5: Reverse
Motor 10: Reverse
Motor 11: Normal

Changing these does nothing - everything stays reversed.

The drive motors are connected to ports 1 and 6, the claw lift motor to port 10, the claw open/close motor to port 11.

There is a bug in the 1.02 firmware. We will be updating to 1.03 shortly with a fix to this issue. I apologize for the inconvenience.

Cool, no worries, I know how these things are! :slight_smile:

Other than that, the kit is great. I love how the robots are so much more robust than those from that other company.

Firmware version 1.03 has been posted and should solve this bug. Run the firmware updater and let us know if there are any more issues!

Problem solved for me!