Drivetrain only goes forward on manual, but goes all directions on autonomous

I put a drivetrain on blocks V5 for my robot to make coding autonomous easier. Before when I had the individual motors coded for driving, it worked. Now that I have a drive train, the manual driving only goes forward OR if I reverse the motors it only goes backwards. I put some code in for autonomous, and with autonomous the robot was able to go in all directions. I have tried almost everything. Does anyone know how I can fix it?

Could you post your code?

I have blocks, so there’s no physical code that’s shown with the drivetrain, but I will still take photos of what it does show. I also have the drive and turn velocities set to 100, and the drive to the right joystick.16070903578218651305335194155648

I would personally recommend programming the individual motors rather than using the drivetrain object bc it is pretty hard to diagnose problems plus it is a lot more educational to program it yourself.

Also, can I see your controller setup?

3 Likes

16070921173971236434968973858235

If you have any code in blocks could you send a screenshot? Also, does it turn at all?

Did you mean left joystick? Based on your controller setup, it looks like the left joystick is the one controlling the arcade drive.
Also, can you post any code that you have regardless if it has to do with the drive.

If you set the motor velocity at 100 then it may just be driving straight at the speed of 100. Rather than setting the velocity based on the joystick.

2 Likes