Drivetrain Problem

My team decided to change their drivetrain to increase speed. It is a community team and I am a mom with no training or experience. Their only experience is with drive trains that have a 1:1 gear ration. They decided to try something new and switch to a chain and sprocket drive system. They built i a 2 motor drivetrain. The motors are on a 24 tooth sprockets and the wheels are on 16 tooth sprockets. When they drove the robot to test it, they noticed that sometimes the robot doesn’t respond to the input from the controller and we hear a whining. They turned the robot on its side to look for an area where it is rubbing and they don’t see anything obvious. They can’t find any consistencies in when it stops driving. Any ideas on how they can solve the problem? Is this their motors dying?

The link below is to a video of what it is doing with it on its side.

Thanks!

2 Likes

Welcome to the forums!

There are a few things that could be the problem. If you could send some close up pictures of the the bottom of the drivetrain or something like that, it could help diagnose the problem better. The first thing that I do would with your robot that could either directly or indirectly fix the problem is put drive rails on the outside of your drivetrain. What I mean by this is that you should put beams on the outside of your drivetrain (i.e. so the outermost part of the drivetrain is a beam going the length of the drivetrain, and the wheels are partially hidden by it). What you are doing with this is supporting the axles on both sides, something that is a good idea to do on all robots and axles with high load, but especially on heavy ones. Here is an example of what I mean:

0305211712

The spacing in the drivetrain or something rubbing is often the problem, but since you couldn’t find any when you looked, that is much less of a possibility. But just make sure to use spacers (both the “skinny” and the “fat” spacers, as I call them). There are several things that could be the problem if this doesn’t fix it, so pictures / video of the bottom of the drivetrain up close would be helpful.

"Skinny" spacers

image

"Fat" spacers

image

Overall, your robot looks pretty good, and just post if you have any problems. I hope this helps, and good luck!

3 Likes

Thank you for the help! I will suggest to them to add rails on the side, I know exactly what you are talking about. I actually suggested that this afternoon and they didn’t think it would make a difference. They have fat spacers between the wheels and beam.

Here is a view of the bottom.

IMG_7728

The metal shaft on the bottom left wheel (in the picture above) is dangerously close to the motor for the strafing wheel, but it isn’t touching it.

It is hard to see the spacing so here is another one that allows you to see the spacing so here is another one that shows it on one side.

IMG_7727

Thank you for your help!

5 Likes

It’s probably because the sprockets don’t have spacers on the outside. They look trapped, and so it would be hard for them to move at all. I’m talking about the place where the sprocket chain meets the beam. Try making the width between the beams and the sprockets wider, and I suggest you add the “fat” spacers on both sides of the sprocket.

4 Likes

Thank you for the pictures.

I am still not 100% sure what the problem is, but here’s a trick you can use if you haven’t tried it already. You might want to add the outside drive rails first to see if that helps, but if it doesn’t fix it then try this. Try spinning the wheels by hand and see if it gets stuck. Then play with it a little and try to find out where it’s getting stuck. Try variants of this until you figure something out. I hope this helps, and just post if there is still problems with the robot. Good luck!

6 Likes

This is a really weird case. I don’t know why the wheel just gets stuck but I have a few theories. It could be the battery, your Tele-op program, or just the drive itself. Like @anonymouse said, the sprockets between the beams needs spacers so they aren’t rubbing against the beams. It looks like the wheels are already have spacers so that shouldn’t be an issue.

Try Swapping the battery for a fully charged one and see what happens.
I would also suggest re download the firmware just in case it is a code issue.

3 Likes

I don’t think it’s a code issue, because the motors were still trying to go when it got stuck (you heard the squealing noise of a stalled motor). So I think it’s a mechanical problem. But if you really can’t find what’s wrong, checking your code and firmware couldn’t hurt.

4 Likes

We hope we have a solution. I told my son to check if the wheels spun freely by hand and that they should have skinny spacers between rubber shaft collars and plastic. When spun by hand, they were very tight so he took it apart, made sure the chains were the same length, added skinny spacers, and charged up a battery.

I think the biggest culprit was that they had used rubber shaft collars on either side of the larger, middle sprocket. He changed those to fat spacers.

IMG_7740

He was able to drive the robot for 20 minutes without recreating the problem.

They are still going to add drive rails but I need to place an order to get the right size beams.

Thank you for all of the help and suggestions! If the problem reoccurs, I will be back.

8 Likes