Drop Link Problems

Today at the Best Robotics ‘Mall Day’ aka practice day, I was working tech support and I ran into a problem I could not solve with link loss problems for a team. They had apparently been out testing for ~20 minutes with no link issues, after which their Cortex & controller kept losing link after ~20 -40 seconds from establishing link. The Cortex would Flash a red light and drop link and a moment later the handset lights indicated the link lost. The Robot continued to flash red led and never tried to re-link.

When they came to tech support we went through the usual litany of troubleshooting , having the batteries changed, Wi Fi Keys, being a Best event there were plenty of spare parts to try thankfully, so we swapped the controller. The team had another Cortex so we tried 2 controllers with their handsets, and went through 3 pairs of Vex Net Keys. In an attempt to eliminate common part faults. From the point I got involved The team ran through the following changes / troubleshooting with me. In all cases they were using the latest Easy C version and ensured we loaded the latest firmware and Easy C Default program and tried to keep link more than 20-40 seconds, but the 2 devices kept dropping link.

Change Batteries
Change Vex Net Keys
Change Cortex
Change Controller
Change Laptop

In summary we had the problem on 2 different Cortex and 2 different controllers. all loaded with the latest firmware and default Easy C code - they tried the team code as well neither configuration of user code seemed to help either.

tried 3 different pairs of vex keys (did not test the pairs in known good handset / cortex configuration and now the parts are back in storage for a week.

I’m sure I could’ve thought of a few more things to try, but we started running out of time. I asked the coach to post here as well and hopefully if anyone has Ideas on what else to try / troubleshoot I would welcome suggestions.

Cheers Kb

we are also having drop link problems with one of our cortex’s since the last release. is it possible that there is a glitch in the new patch?

Kevin, latest EasyC for cortex is, that’s a PIC version I thought.

What was the master firmware version ? Was it 3.23 ?

Did you test with or without a competition switch (does that even apply to BEST) attached ?

Was the backup battery good?

Hi James,

Sorry I didn’t record the Firmware version, I am not as familiar with Easy C anymore. I’m not sure how to check. I am hoping the coach will join us on this thread. However what the students told me is that they are using the current version of Easy C which I agree is I have no idea where I got the version except I did just get a raspberrypi and it may have influenced me. :wink:

As far as backup batteries they are not used in Best nor is the competition switch. There were at least 14 other teams that were at the event no one else seemed to have this problem.

Cheers Kb

I worked with this team from the onset of their problem. The only other thing to add is these kids originally compiled their code in the competition project environment. I watched as they copied and pasted the code from the competition project file to joystick project file. Other teams who had made the same mistake did not copy and paste their code into the joystick project and hey did not experience the problem.

i have had problems with two cortexs since i updated the firmware to 3.23 … and after the second cortex was messing up, i didn’t update the third … and the third is fine … since then i have re-written the firmware and program etc … seems to work a little better … but still on one of the cortexs, the link establishes … then after about 20 - 30 secs it drops (red vexnet) … and the motors keep running … we normally have to turn it off / pull out the battery

if anyone has any ideas how this can be fixed, please reply


I didn’t read this post prior to adding my 5 cents earlier.

I’m guessing that the competition switch that you are asking about is the type pf project. joystick/competition. Yes, they did originally compile and attempt to download the cortex with the competition switch.

The first problem they experienced was the inability to download the cortex. At that point I verified their firmware and EasyC revision. That’s when I noticed the competition project switch. As I was explaining they should be using joystick. One of the kids already had a new project created and had cut, pasted and was compiling the code before I finished speaking. They downloaded and tested their machine on the game-field. 20 minutes later they came came back with vexnet link dropping. We never got them working again after that.

Actually I was talking about the external switch that connects to the joystick and simulates field control, however, I understand BEST does not use that feature. The reason I was asking (without elaborating in the question) is that a different WiFi channel is used when the cortex is in “competition” mode with field control/competition switch connected. This has nothing to do with the type of EasyC project selected other than a competition project can act just like a joystick project if there is no field control but not the other way around. Anyway, back to your problem, Kevin said you tried the EasyC default code, is that true ? If it is not and you only used the student’s code then that would seem to be the most likely candidate here if, as stated, every other piece of hardware was changed (cortex, VEXnet keys, joystick etc.). Can you be any more specific on the LED status, Kevin states the ROBOT led flashes red (normally a battery issue) but what about the VEXnet led ? Can you tell us anything about the ROBOT configuration, forgive our ignorance about BEST, how many motors? Were the (infamous) integrated motor encoders used etc.

Can you post the code so I can try it on another system and try to reproduce the issue?


Can you send me code that fails on your system. I’ve been running 3.23 on at least four cortex controllers with no problems. 3.23 (if the wiki is correct) is very close to 3.17 worlds version, I suspect almost the same and just a clean up of the version numbering.