Easyc competition switch not connecting with controller

Hi, we’re students from a pre engineering class. We got a programming challenge to program our robot in autonomous mode.

We’re having trouble switching our robot to autonomous mode through Easy C’s competition switch simulator.

We have an ethernet and phone cable hooked up to our controller from our laptop running EasyC 4.0 and a tethering cable from our controller to our cortex.

When we click the competition switch simulator it tells us that it “Cannot activate competition switch simlator. Failed to write device.”

We have installed and reinstalled the serial drivers available on the VEX download page numerous times and it still doesn’t work.

Does anyone have any tips?

Students of FH Pre Engineering :smiley:

You cannot use the compeition switch simulator software and compeition switch hardware. You can only use one or the other. You also need to use a compeition template.

Hi kingofl337

We don’t currently have a competition switch hardware; we’re only using the simulator. We’ve also tried it on a competition template to no avail.

Do you have any other suggestions?
Students of FH Pre Engineering :smiley:

First you must use a competition template to use the simulator.

You have to plug the USB to “Phone Cable” Programming cable plugged into the primary controller. (With the USB Key) You should not have anything connected to the competition port on the joystick.

Alternativly, you can also use a timed competition project. This will allow you to run through a match just by pressing a button on the main joystick. It will run autonomous and then operator controll based on the timed values you entered. When you goto compeition and connect the field, the timer will be disabled in favor of the field control.