EasyC v4 for Cortex will not run

Whenever I try to run EasyC 4 Cortex it crashes with an error message: “The specified module could not be found. Please restart the computer.” Once this happens, I have been unable to get it to work on that machine ever again.

This is happening on an increasing number of computers at my school. Both laptops and desktops are affected, though it seems to happen more on laptops. There have been no hardware or software changes to the computer prior to the error’s onset. EasyC will work great for days, weeks or months, then it will refuse to run from that point forward. I can’t figure out what is triggering the failure; it was not preceeded by a crash, improper shutdown, or any of the usual suspects.

I have called the manufacturer several times on this and they have been unable to fix it. I’m hoping someone on here may have found a solution.

Here is what I have tried so far:
[LIST]
*]Resetting the computer (as the error message requests).
*]Uninstalling and reinstalling EasyC. (same error upon first attempt to run it)
*]Uninstalling Easy C, rebooting the computer, manually removing all refrences to EasyC from the registry, rebooting, and reinstalling EasyC from a fresh download. (same error upon first attempt to run it)
*]Running the licensing engine removal and repair utility provided by Intelitek. (same error upon first attempt to run it)
*]Reimaging the computer, then installing EasyC from a fresh download. (same error upon first attempt to run it)
[/LIST]
EasyC Error.JPG

Hi Ray,

Unfortunately, I can’t provide a straightforward “do this” solution to fix it but I do have a couple suggestions.

#1 - I’m assuming the software was installed properly and the licensing engine / registry hasn’t been modified. Uninstall EasyC, reboot, reinstall EasyC, reboot, wait 5 minutes (seriously, wait 5 minutes)… This allows windows to fully load and link all the licensing engine .dll files. Start EasyC.

#2 - This may be a permissions issue between accounts. Was the software installed under one admin account then licensed under a different admin account? Does the error occur if you’re logged in as the admin who installed and licensed the software?

#3 - I’ve seen conflicts with virus prevention software preventing the install of the licensing engine files. Can you disable the virus scan then install and open EasyC do you still get an error?

#4 - contact me via e-mail TPope@intelitek.com with your support ticket number (NSC1400***) and contact information (Name, School, location and phone number). To save redundancy, I’ll review the troubleshooting our support team has already performed and if necessary, will elevate the issue to our Development Team.

I will do that tomorrow during my planning period. Just before leaving today I tried uninstalling EasyC and received this error, which is a new development:

Error Code:	-5006 : 0x80070002
Error Information:
>SetupNew\setup.cpp (597)
PAPP:easyC V4 for Cortex
PVENDOR:Intelitek (www.intelitek.com)
PGUID:9AD8A944-31B5-4C6B-86D5-AC58F23497AA
$19.0.160
@Windows 7 / Server 2008 R2 Service Pack 1 (7601) 
IE Version: 9.0.8112.16421

I’ve seen the “Specified module could not be found.” error too. During installation I got an error that /Windows/sysWOW64/socx5.ocx wouldn’t register. This is a library apparently used for the license and registration of EasyC. My solution was to copy the file from a working system, register it with regsvr32 (using complete file paths), install EasyC, and reboot.

Do you get any errors during EasyC installation about any files ending in .ocx not registering?