Error when updating firmware

I followed the instructions at VEXos Firmware Updates - Products - IQ - VEX Robotics and plugged all the components in and then turned on the brain then connected to mac via usb. I then went to the utility application and clicked install. All seemed to be going ok and a couple of the components turned green. Then it turned the brain off and told me to turn it back on. When I did this I now get a message ‘Connect to PC for Program Update’ V1.01.
I have tried removing the battery, restarting the mac, etc. still get the same message.
The utility application also hangs. The image that shows the brain and components now no longer appears and its stuck on the first screen.
The brain screen is now stuck and I can’t use it.
I am running MacOS 10.13.2.
The VexOS utility is Version 20160923.
Any help much appreciated.

Other people have complained about the Mac version. Short cut may be to find someone with a Windows PC to help you out. Sorry

I’ve had trouble on the MAC, getting the pinwheel of death sometimes