Exactly how to update Vexnet/firmware

Basically Vexnet updates have screwed me every year just in the nick of time before our competitions.
I’m trying to follow this instruction manual: (forgive the long link)
I tried upgrading the joystick and I think I got that to work.
When I try to upgrade the cortex microcontroller it looks like it’s working (“writing sector 8”, etc)… after the download bar reaches 100%, text says “waiting for CDC 15”, with that number going up to about 60 before something flashes rather quickly, I think it is green, before returning to the red “connect a VEXnet device”. Is this normal!?
If I try do build and download a proram Easy C says “failed to Get Vex System Info (trying to get system info with the cable unplugged.)”
It’s plugged in.
I’ve got EasyCV4 for Cortex, which I think is the new version. I am using (or at least trying to use) the V 3.1.6 upgrade utility.
Please help, if anyone at all remembers what they did when they updated their team’s VEXnet.

The VEXnet upgrade utility will show “VEXnet is up to date, No action required” with a green background if the cortex has been updated (when you plugin the cortex USB).

Have you loaded the new vex driver? you should see a “Vex Robotics Comm Port” under ports in the device manager when the cortex is connected. Not sure if EasyC loads this automatically, the path for the driver is C:\Program Files\Intelitek\easyC V4 for Cortex#Tools\Drivers\VEX Programming Driver

Thanks, I foundthe comm port in the device manager and reinstalled the drivers. Now it works.
Thanks for your time, hopefully I won’t be back here again next year with more problems.