"Failed to download program" message - also posted in Unofficial Thread

I realize this is a duplicate post (it’s also in the Unofficial Support Thread). I’m not sure if I posted it there by accident, or if it was moved. However, since there have been no replies to my other thread I thought I’d try here as well.

“Failed to download program” message
I am Tech Support for a school district. I have a Physics teacher that is trying to use the Vex robots. He is having some issues, and I was hoping you could help. Below is the e-mail I received from him:

.“When I tried to load the program onto the robot the IFI/intellitek loader screen pops up and says, “Failed to download the program. Make sure that power is on and the serial cable is connected.” (Which I have on 2 different laptops). I just tried it on another laptop and when I try to open the program it says, “the specified module could not be found. Please restart your computer.” (which I did and nothing changed).”

Sorry there is not more information; this is about all I can get from him. At this point I am not sure if there is an issue with the VEX or with the Easy C program he is using. Can anyone shed some light on this, or point me in the right direction? The laptops he is using run Win 8 64-bit.

Hello jmascherino,

Thanks for taking the time to visit our forum.
I moved your post because based on your question, you will get more feedback from the open discussion community forum, than from the closed discussion official answers forum.

Based on your description, it looks like easyC is having trouble detecting your hardware. What I recommend is to download the default code into the Microcontroller using the “IFI VEXnet Firmware Upgrade?”
Attached is a screenshot with instructions.

Let me know your results.

Doc1.pdf (268 KB)

Thank you for the response. I will forward the instructions on to the Teacher that is having issues.


Sure, let me know your results.