failure in linking to Cortex with new EasyC 4.0.4.6.

Just updated the EasyC to the new V4-Cortex : 4.0.4.6

using two different computers (both XP), have the same problem. update seemed to go just fine. Then when downloading the code for first time to cortex, the new V4 program says to update the firmware. Firmware started to go as normal. Boot loader seemed to work as normal, then a message in the boot loader that said something like waiting for CDC with a counter that was counting up. At the same time a Windows Pop UP window shows up that said new hardware detected and wanted me to update or laod a CDC RC driver. My system cannot find a CDC driver and then fails to instal this new found hardware. I have a screenshot attached.

I have two computers that did the same thing with two different Cortex boxes. I now cannot establish communications with the cortex controllers. I did perform the Prolific (sp?) USB driver executable that is in the driver folder of the new version of Easy C, but that did not help or improve anything.

Note: I also had the original XP disk in the drive for my system to find a CDC RC driver, but that did not help.

We would appreciate any quick assistance with this issue as we have a competition this weekend and our team is now down. Thank you.

shane.a.campbell@delphi.com
2012-02-22_07-18-15_694.jpg
2012-02-22_07-17-34_429.jpg

The new firmware uses a new USB-To-USB Serial Driver. Just click next and continue until the driver is finished installing. Then unplug and replug the USB cable and you should be set.

Don’t forget to update your joystick as well.

The “found new hardware” routine does not work. It cannot find the appropriate driver. We have experienced PC users doing the upgrade to the new version and others have already looked at the obvious “user” type errors. We believe this to be a real issue as it has happened on two out of two installs using two different computers (different vintages) that do not have the same applications loaded.

The found new hardware does not recognize the new USB drivers, but we have however run the .exe for them. Still no connection.

The EasyC error messages say something like “trying to connect with the cortex with the cable unplugged”

I have attached two more screenshots.

This may not be an issue with Windows 7, but I do not have Easy C on a Windows 7 machine to try. - does not really matter, as we need the Easy C working on our Windows XP machines.

Let me know the next step(s). Thanks.

shane.a.campbell@delphi.com
2012-02-22_11-25-34_381.jpg
2012-02-22_11-25-15_109.jpg

Try going to Start -> All Programs -> easyC V4 for Cortex -> Drivers -> Vex Programming Driver Installer.

Then go through the windows driver install wizard.

Also, when you install easyC it asks you if you want to install the “Vex Programming Driver” (defaulted to yes) Make sure you don’t click no.

Okay, we are now running, BUT… this is what we had to do (we tried many times and are convinced, at least with our computers, we had to follow this proceedure):

  1. uninstall the pre-4.0.4.6 version of EasyC from our system

  2. run the .exe file for 4.0.4.6 version of EasyC

  3. make sure all option boxes are checked so it will install the USB-Serial Driver

  4. restart computer (maybe even between installation steps - if asked to do so)

  5. plug in USB A-A cable to connect to Cortex controller.

  6. hopefully the Found New Hardware pop-up will say something like “Easy C USB” instead of “CDC RC” for the type of driver it wants to install. Allow the pop-up to install or configure the driver.

  7. The firmware on the Cortex can then be upgraded using the firmware loader

Note: if we did not un-install the previous version of EasyC first, we could not get the Pop-UP to look for the Intellitek provided driver.

we only have experience using Windows XP, have not tried upgrading on a windows 7 machine yet.

Looks like the new EasyC will be very powerful and fun to use.

Note to mentors/coaches >> Do not just let your students use the PID functions without them understanding the concepts. I believe they should “build/engineer” thier own PID control and demonstrate they can make the robot drive straight and with speed control using their own ingenuity first. Once they have understood the concepts, THEN they can use the one-button approach and use the power of PID control. Just my opinion.

I’m sorry your driver did not install, but this is not the normal case. The XP driver installs automatically on 4.0.4.6 pending you don’t select “No” during the installation. Though you have to go through the add hardware wizard once the device is connected. On Win7 the driver just automaticly installs with no prompts.

The reason you had difficulty, is you upgraded from a HID version of mastercode directly to a serial version. There have been a few versions of easyC that use the serial USB-to-USB driver, you just made a bigger “jump”. Make sure you update the joystick as well.

You do have to update your mastercode, as the software checks and recommends you run the current mastercode. It can be bypassed it, but it is not recommended.

As for the PID, we recommend reading the help file, and playing with it a bit on a loose motor before just slapping the IME motor on the robot. The default PID values aren’t very aggressive and the control was designed so beginners can get going quickly.