Faulty Motor Controller?

Hi all,
In the last little while, a problem has risen out of no where, as in, it just spontaneously appeared. We have a robot for the Sack Attack competition, and when we try to lift a large weight we were able to previously, the motors will let go and will not move more than an inch unless we don’t touch them for about 5 seconds, then everything is fine until we try to lift that weight again. After replacing the motors, the problem still exists, and we have hooked a dual battery system to it as well, its not helped either.
I cant figure out why it was working before and not now. Is it possible that the motor controllers are at fault? Or is it some other problem?
Btw we are using 2x 393 motors, one at each side of the arm, moving together, same gear ratios and everything.
Any help would be much appreciated! Thanks! :smiley:

What type of lift are you using, what are the ratios, how much weight is it, and how high are you lifting it?

You are tripping the PTC (essentially a thermal fuse) in either the motor or cortex. It’s most likely the motor, search the forums there are dozens of threads on this issue. What’s your gear ratio? How heavy is the arm? How many sacks are you trying to lift?

Here is a post with the type of calculation you need to do to verify where in the motor torque-speed curve you are operating and therefore if you are likely to trip the PTC in the motor.


Edit: I should have welcomed you to the forums, don’t worry about the calculation I pointed you at, once we have a better idea of your design and what you are trying to pickup then we will figure out what you need to do.

Like jpearman said, you definitely could just be tripping the internal fuse for these motors, depending on the load you’re giving them. Despite this, our team has found that we’ve had just as many faulty motor controllers as deficient motors. The fact that you could have lifted these weights before (assuming nothing else changed) makes me suspicious.

Could you lift it before with ease? If so, it’s probably not the motors.

Can you identify a specific motor (left/right?). An easy test to see if it’s the motor controller and not motor itself is to see if a certain side is noticeably worse than the other. If one side is worse, switch the motor controllers and see if the problem reverses. If the other side is now worse, it’s almost definitely the motor controller.

Last note: broken motor controllers are usually associated with motors that are “stuck”. That is, when the cortex is powered and the faulty controller is attached, you are unable to manually turn the motor with ease.

Hi everyone, thank you for your replies. I have solved this issue.

Turns out that it wasnt the motors or the controllers after all. Part of the design was to bring the arm in closer to the robot to make the “hand” part more flush with the ground. If I did this for too long, the arm would stall out. Though I am still not sure why it worked before, I implemented some code into the programming that will make the motors not exert so much force.