Few issues - downloaded project not working or download button stays gray

Just did our mentor bootcamp since our teams start Tuesday and we had a few issues while testing out VEXcode for IQ with our Chromebooks.

  1. From time to time the download button was gray and new code could not be downloaded. Everything has been updated, project saved, slot picked, program seen the brain, but the button remained unclickable. To solve we had to reboot the program, sometimes more than once.

  2. We would save the successfully download a project to the brain, try to run it and get nothing. The robot did not run the code at all. Only solution that worked was to make a completely new file and keep retrying. Luckily this was just at the beginning, so only a few lines of code. No clue why this happened at all. The code in the new file was exactly the same.
    Again, everything up to date, project showed in the slot selected, but just would not run.
    Even checked that everything was fine by using teleop.

Just wanted to report in case anyone else was having the same issues or we are just missing something!

Sorry about the issue you’ve experienced with VEXcode IQ Blocks. We just released an update today that fixed a number of reliability issues with Chromebooks when talking to the VEX IQ. Please try the new version and let us know if you’re still running into the same issues.



I have the same issue where it stays grey and does not click, i have the latest version by the way.

Can you provide more detail on the issue? Which operating system are you using? Has this computer worked work with any other IQ software packages? If Windows/Mac, are you able to run the VexOS Utility?

1 Like

I used vex iq blocks on chrome book, i take the cable out than in and it still does not download anything. also the first time I open vex iq blocks it lets me download it once but it doesn’t
transfer to the robot after that the button is grey and i am not able to click.

It might also be helpful to list your Chromebook model and OS version as well.

Few other things to ask - what firmware version is your VEX IQ on? Have you tried another USB cable? Do you have any other software packages installed that may be using the VEX IQ connection (I.e. chrome plugins)?

The detail that you’re able to start to download the project but then the connecting hangs implies that something is preventing the IQ from acknowledging the download. We see this issue on PC / Mac when users have both VEXcode V5 Blocks and Text open at the same time, but have not seen it with IQ.


Yes i have tried 2 other usb cables i got the software from the chrome store. the firm ware says its up to date, I also tried the one on the vex website and it still doesnt work, i just deleted one of my coding files so there was no progress, so i made a new one with only 12 kilobytes, is there a limit to how much storage it is? or is there just a really long time to download i waited around 20 -30 minutes and nothing was there. This is not i big issue for me becuase i will be getting a macbook and be using that OS instead.

Thanks for the info. Project files will scale in size with the complexity, 12KB on disk doesn’t mean 12KB to the robot. Downloads definitely shouldn’t take 20-30 minutes however - more like 1-2 seconds max.

Do you know what model Chromebook you’re using?

its a chrome book spin 11 , also i just tried it on my cousins mac air and it worked so i think the issue is on chrome.

We’re actively looking into this issue and sourced a similar model to investigate if we can reproduce this issue.

One other quick question - is this Chromebook “managed” at all? Meaning is it a school computer?

1 Like

No it is my own, i bought it about a year ago for school but im upgrading to something else.
Thank you for looking into this. : )

1 Like

Okay, managed to get a Chromebook Spin 11 and didn’t run into any issues running a project on the VEX IQ Brain from VEXcode IQ Blocks.

Two more things to check…

  1. On your Chromebook, can you go to “Settings” -> " About Chrome OS" -> “Detailed Build Information” and post what you see under “Platform” and “Firmware”.

  2. With this VEX IQ brain, have you used this brain with ROBOTC or Robot Mesh Studio using Python? Both programs resize slots on the VEX IQ brain, which may cause problems when trying to overwrite old ROBOTC / Robot Mesh Studio programs with a VEXcode IQ Blocks program. To clean out old programs, go to “Settings” -> “Erase User Programs” and confirm you want to erase user programs by pressing the check button. After doing this, see if VEXcode IQ Blocks works from your Chromebook.

1 Like

firmware: Google_Reef.9042.220.0
platform 12105.100.0 (Official Build) stable-channel reef
And no I never used anything but iq blocks, i got the kit less than a week ago
I waited like an hour later and it just downloaded, i geuss i had to just wait, thank you for supporting me.

Glad it’s working! Since it’s a new kit, one additional thing you may want to do is use a Mac or PC to make sure your VEX IQ Brain, Controller, and Sensors are up to date using the VEX OS Utility.

1 Like

yeah it works but i had one last question its about the coding part, the code is half autonomy s and half is manual, when it starts is it possible to make the user of the controller not be able to move for around 5 seconds while printing a message?

This concept is being discussed in another thread… if you program the controller interface yourself, yes, but using the “Devices” Controller configuration it is not.

Reviving thread since we are having similar issues again with one of our Chromebooks.

Model: Acer Chromebook 14
Firmware: Google_Lars.7820.376.0
Platform: 12371.75.0 (Official Build) stable-channel lars

All Robot parts are up to date with firmware via VEX OS.
The file is saved, connect to the brain and VEXcode sees it. The Download button is white, we click it, it fades and nothing happens. Code does not download. No error messages. Button stays “gray/faded”.

Checked for any update on the laptop and everything shows up to date. Tried different cables.
Also restarted the program several times and the same thing happens.

Tried one of our other laptops (Lenovo Chromebook S330) and it worked, so now we are trying to figure out why just this one? (however, not all the other laptops have been checked in a few weeks, just the one as they are building and not everyone is ready to program just yet)

This laptop has not been used with any other applications. New this year to our team and our own, bought by myself. Only used for VEXcode and internet (game manual, etc…no browsing)

Any thoughts here on what could be the issue or how to fix it?

When you click the download button on VEXcode IQ Blocks, does the IQ Brain stop responding? If so, try resetting the IQ Brain’s catalog by using Settings -> Erase User Programs.

The fact that the Brain is being seen by the VEXcode IQ Blocks means it’s a different Chromebook issue than before. The previous issue was related to how some Chromebooks would enumerate USB devices in a way our device manager wasn’t catching.


Nothing happens on the brain interface and the laptop still recognizes it’s connected. It’s just the download button fading and not actually downloading.

For what it’s worth I tried to download the same file on another brain and it did the same thing.

Previously when we had the download button fading issue (stated above) we deleted the file and wrote a new one. Obviously that’s not a viable solution. This team has a LOT of code written and would not want to do that now!

I will check each Chromebook tonight to see if any other is having this issue.