Firmware update problem


I have received my Vex IQ super kit since last 1 month

Since last month, we tried to update firmware many times but we are still getting error as soon as we start the firmware update software, we get the following error

“The utility could not perform its initial update
please try again later”

I turned off my firewall and tried to update on at least 3 different machines still the same problem.

I would greatly appreciate if you can provide any suggestion to resolve this problem.


Hi rajtest,

We’re sorry that you are having this problem. The VEX IQ Firmware Update Utility needs to connect to on Port 80 to download the latest firmware files. Please check with your school IT administrator or parental control software to see if these are blocking your connection to that URL.

It is also possible that school IT policy blocks downloading files of specific file extensions - if this is the case you will need to have .bin added to a whitelist (this is the Robot Brain firmware) and .txt added for all other sensors/devices. If you are still having issues or have further questions, please contact VEX Technical Support at or by calling +1-903-453-0802.


  • Art