Firmware Update withe new VEXos Utility (updated July 2016)

Installed new VEXos Utility for Windows (updated July 2016) and tried to connect a brain to the computer. The brain is not connecting and says “Connect to PC for Program Update” when turned on. Used old software called VEX IQ Firmware Update on a different pc to connect and update two other brains. Then tried to connect the brain (that did not work with the new software) to the new computer with old software and the brain along with the motors did not connect. The brain continued to say “Connect to PC for Program Update”. How do we reflash when we get this error?

Any suggestions to fix this connection problem would be appreciated. Thank You!

If you plug in the brain that is showing the “Connect to PC for Program Update” into a PC with the new VEXos Utility installed you should see this screen on the VEXos Utility (See Attached Image). If you don’t see this screen it most likely means that the PC is not recognizing the USB connection. Here is a couple things you can do to verify what is going on:

  1. With the brain plugged in to your PC and powered on, open Windows Device Manager and see if you have a device entry titled “VEX Device Firmware Upgrade”. (See image attached)

  2. If that entry exists make sure you do not have any other VEX related software running and restart your VEXos Utility. If the utility still does not show to be connected call Technical support.

  3. If the entry does not exist in the device manager list try this.
    a. Move the USB cable to another port on the PC
    b. Try a different USB cable
    c. If the above fails, disconnect the brain from the PC and uninstall and reinstall the VEXos Utility.

If all of the above still does not fix it. Give Technical Support a call.

Sorry about troubles. I hope this helps



Levi – I would also restart my PC and try this all again. USB ports can be strange.