Firmware updater problem

I’m trying to update the firmware of my VexIQ. When installing the updater, I get a message that drivers were not able to be installed. I still tried to proceed, The updater does not recognize anything plugged in.

The uninstall link in the start menu does not work.

The uninstall utility from the control panel does not show any Vex program (even though the uninstaller does show up–though not working.

Tried restarts, battery unplugs etc.

Any suggestions? I have Windows 7 Pro 64 bit operating system.


We’re sorry for these issues that you are seeing.

The VEX IQ Firmware Update Utility requires an administrator account on Windows to install itself and the VEX IQ drivers. If you are in a school or classroom environment, you may need to contact your IT system administrator to have it installed.

If this is your personal computer, please verify that you are accepting any popup access alerts from the Windows U.A.C. (this is when your screen will go dark and a single Windows popup will ask if you want to continue). You may also need to check whether your anti-virus software or parental control settings are blocking the installer from properly running.


  • Art