fun with a (possibly) busted cortex...

The middle school team I mentor was having some problems at a tournament yesterday…

Their bot operated perfectly in the qualification matches, but something strange happened during the elimination rounds. When they were on the field, it didn’t move. There was no mechanical failure. As soon as the robot was removed from the field control system, it ran fine. Their batteries (main and 9V) were fresh, their code (easyC) was downloaded and re-downloaded, and all of the software was up to date with the latest versions. It’s just that connection with the field meant certain immobility for them.

In addition, whenever they operated off of the field, the “robot” light on the cortex and controller blinked a slow red (like it was disconnected) but all other lights were green. It, even with this red light, moved with no problem.

The question is thus:

Has anyone had these problems or symptoms? Is there any diagnosis based on the description? (I’m guessing the cortex might be busted, but really I have no clue at this point)

Thanks for your help on this! If you need more details, just say so. I don’t know everything about the robot, since the kids put it together, but I’ll try to help as best as I can.

I saw this one time last year. We never figured out what caused it, and I’ve never reproduced it since.

Are you using a partner controller?

They were using a single controller. the mystery continues…

The one thing we didn’t try to swap or change was the vexnet keys. The next time they have practice I’ll suggest that they try it. Then again, there’s no guarantee that this will work, either

Yeah, sorry. We fixed this last year by swapping out the coiled handset cable and partner controller. And for the life of me, I have no idea why that worked. They grabbed one of our other team’s partner controllers when they left the pit because we had taken the batteries out of theirs to charge, and the problem went away.

If you can figure out what happened there, I would be amazed.

Challenge accepted…

So, to clarify: this bug occurs only when connected to a field controller? When disconnected, it works fine?

Yes. It doesn’t respond when connected to the field controller.

When disconnected, the “robot” light shows a slow red blink, but the bot runs fine.

Does the “slow red” led match any of the animations in this post?

To me, “slow red” would mean a discharged cortex battery. Field control may be working but the battery voltage may be so low that the robot cannot move.

Competition / Disabled / Single joystick / discharged (or disconnected) main battery / Good backup battery

It matched this one. Except the robot moved at full speed with no problems at all when they were not in field control. It even worked perfectly using their own competition switch. They also changed batteries with freshly charged ones and still had the same problems.

reflash the cortex master processor firmware (the 3.23 version, not the EasyC code) and see if that fixes the issue. Then if that doesn’t help, try another joystick or reflash the joystick firmware.

I’ll get the kids to try a reload of the firmware the next time they have practice, thanks!