Getting memory permission error 038026D8 In Vex V5 Brain

Getting memory permission error 038026D8 In Vex V5 Brain. This is a run time error I am getting while trying to make a library that my team can use for their robot development. (It is also my first time writing a library in C++). I have tried removing as many pointers and fixed when for loops are going out of bounds. Not being able to debug in run time has made this difficult to fix. Any help would be greatly appreciated.

One thing you need to be careful of are global constructors, for example, you cannot use Brain.ThreeWirePort before the Brain instance has been created, the order that global constructors are called is not guaranteed across different files.
Anyway, if you want to zip up the project and PM it to me I will have a look.


I tried to do a good job of instantiating motors when I was using them inside a different file but this could still be part of the problem. I will PM you the project.

fixed the issue!! I ended up finding using the motor_group implementation in the vex code docs. It worked flawlessly as opposed to my custom motor group implementation. That was causing the problem, I was using some arrays and pointers and some for loops were causing problems. Thanks again for all the help!