Gyro detected as TouchLED

Today Gyro sensor identified as TouchLED by firmware updater and auto-updated TouchLED and Gyro at the same time!

This season up to now nothing has changed except for brain firmware update from 1.12 to 1.13. We had two runs in a tournament and then suddenly it needed update to a motor on port 8 (per LED display). During the update with latest updater, it identified it needed more updates. Upon clicking updates to “Touch LED” sensors, it looped 5 or 6 times and updated two ports 7 and 9. One was LED and one was Gyro using that “Update” button. Gyro has a separate button actually but it did not show update required.

The robot was slow for 3 following matches. Then it showed a problem again on LCD display. After downloading program again in RobotC, it displayed screen that showed identified hardware as TouchLED though our program had it as Gyro. Closed the program and went to firmware updater. Now Gyro was not detected. We had to replace the Gyro sensor. This time download worked. Program or wired port was unchanged.

Our conclusion is that the firmware actually causing these devices to fail based on firmware “auto-loading” firmware into the wrong port? Please advise. Thank you.

I just replied to your other post. The information isolating gyro issues and updating gyro firmware is relevant here. We haven’t noticed the slowness that you are reporting, but will be on the lookout for it

Original reply=======

We have noticed this too. Especially with the gyros. Sometimes the brain reports that a motor needs to be updated, but it turns out to be a gyro in the same bank of ports. Diagnosing this problem is difficult; teams that have not previously experienced this will try replacing the motor and the cables connecting it (as would be logical).

Now that we’ve come across this issue we know what to do. 1. Take off the gyro. 2. Plug it into port 1 of a different brain. This second brain should have nothing else plugged in. 3. Run the firmware update tool on the second brain. 4. Chances are that the firmware tool will say that the gyro needs to be updated. 5. Update the gyro firmware. 6. Move the gyro back to your robot.

If the firmware tool does not say that the gyro needs to be updated, then maybe it really was a bad motor in the first place.
http://www.vexiqforum.com/forum/main-category/technical-discussion/7133-update-needed-screen-on-lcd

Thanks jrp62. We have come across this where Gryo went bad (we have several sensors go bad from the same superkit back-ordered, delivered 2 months back). We have seen where motors were reported bad (I2C error) where the cause is one of the other devices. As this happened during a match start, we were given about 1-2 mins to fix the problem. We quickly ran the firmware updater. It updated the motor and button disables fine, then Touch LED button enables (which was previously a check mark of up-to-date), then we clicked update. That is when it (updater) looped multiple ports (ie, touch + gyro) on its own several times. It was in the same bank of ports but the auto-looping was a new feature; Gyro itself is a separate item in the updater. Everything ran ok now but very slow. Then we turned brain off and on after a bad match. Now another error. What followed was a no-Gyro at all. When hooked up to a debugger, Gyro transformed into a LED. We replaced it with an older one, worked.

I will hookup that gyro this week to see if I can recover it. It is brand new.

Hi surgeon,

We’re sorry that you have encountered this issue; we are currently investigating this issue of a sensor appearing to the Robot Brain as a different type of device. Please contact VEX Technical Support at support@vex.com or by calling +1-903-453-0802 so we can help resolve this situation.

Regards,

  • Art

Hi Art,
We have contacted Vex. Working on this and other issues. Thank you.

Regards,
surgeon

Two days ago another Gyro became a touchLED by itself while going from brain firmware 1.12 to 1.14 with everything hooked up. So it appears it has something to do with 1.12 and 1.13 (incorrect device identification so far) where it meets some condition and it just transforms. Then plugging it in by itself to port 1, the updater no longer detects Gyro. It is still a TouchLED. Even hardware shows it as TouchLED, with values but you cannot change them though.

Then I connected 2 sensors to see if it makes any difference after brain, all motors (now unhooked), controller (now unhooked), and sensors were up to date. It did detect both, with Gyro still a LED.

307774050711c1214d2a13eb200c8e59.jpg

b0bbb28ec52adcb9d0d887102037b091.jpg