HELP AUTONOMOUS CRASHED


#1

I don’t know if anyone else is experiencing this issue but my robots autonomous yeeted on itself. It literally just started spazzing out and not doing anything that I coded. I restart the robot and it works perfectly fine, minutes later after not touching the robot, I run the autonomous and it starts going crazy. Its like the motors got flip flopped or something. I checked to see if it was something in the code multiple times, I got it double checked by multiple people and re downloaded it multiple times. It works fine sometimes and then goes crazy other times. I think its with the brainor something. Everything is up to date. Why is this occurring???


#2

What program are you coding with? Are you using V5 or Cortex?


#3

We are coding with v5 using vex coding studio. This problem just occurred today, we had a fully functioning autonomously until it randomly crashed. This has to be a vex problem because I didn’t change the code other than for some very minor tweaks and then switched it back to how it was and it never went back to normal. I even made copies of the o.g. code before I tweaked it because I know how glitchy the system is. This is SOOO unbelievably frustrating…


#4

I’ve heard this so many times over the last several years.,

post the code so I can have a look,.


#5

try writing a super simple auto to make sure it isn’t your code. like move forward or something. and see if it still bugs out


#6

I did that, before we were using a formula and a method that calculated the rotations in terms of degrees after we input a desired distance and it worked fine until out of nowhere it crashed. Then to make sure it wasn’t the code, I made a super simple one and it once again didn’t work at all. All the ports are correct and the directions are too because driver control works perfectly. I’ll post the simple code just so you guys can check. This needs a fix asap. It costed us our tournament.


#7

I have attached a version of our simple code that once again didn’t work. The weird thing is that it was working perfectly a couple of days ago and then out of nowhere it started freaking out. And I restart the brain and run the autonomous and it runs about halfway through it and then freaks out again and then I re run it without downloading or chaninging anything and it remains crazy. And it’s super inconsistent, one minute it’ll work and the next it’ll freak out. I could even take a video the next time I’m with the robot to show you what I mean. I haven’t heard any other teams encounter this issue.
MiddleTown.vex (46 KB)


#8

Everything is up to date by the way. All firmware has been updated.


#9

hmmm… well you know it isn’t your code if a simple program still bugs out. does this happen with multiple brains?


#10

I don’t see anything obvious on first look. I will run it in the morning on a V5. I’m thinking you may have a hardware fault on the brain.


#11

I have another brain to test with, Ill see if thats the issue


#12

thank you


#13

Have you found any issues with the code or any new insights with brain defects, etc?


#14

@mvas8037 I might be able to provide a hint of insight into a few of your problems, first I would recommend placing encoder sensor resets at the start of the code in order to make sure you have consistency every single run. Second, make sure firmware is fully up to date and also try resetting your brain to factory default. And third and this one is kinda large, do not immediately jump to assumptions that it is someone else’s fault that your autonomous is working improperly. Making mistakes is common and in this venue is welcomed. Don’t stress that you didn’t do something right the first time, it is perfectly ok to be wrong.


#15

only two issues I see.

  1. you have a while loop surrounding all your autonomous code, so it will try and run over and over.
  2. you do not reset motor encoders when autonomous runs, so if the motors have moved by driving etc. you will start the auton with encoders on undetermined values. As the drive uses rotateTo (absolute move) rather than rotateFor (relative move) that may be an issue.

#16

thank you