Help Connecting Brain and ROS using rosserial

Hi first time poster so sorry if I break any rules and let me know if I do. I am trying to connect ros to the v5 brain so that the brain is a node using: https://github.com/UTAH-VEXU-Robotics/rosserial/tree/melodic-devel/rosserial_vex_v5 and https://github.com/UTAH-VEXU-Robotics/ros_lib.

However, in trying to run the hello world example, I get this:
error

I am pretty new to ROS and vex so any advice on how to fix this would be much appreciated.
In terms of general info, I am using Ros kinetic on a raspberry pi running raspbian. Let me know if any other info is needed and I can provide it.

Hi welcome to the forum! You seem to be following all the rules. Just a small nitpick: you can change the topic from VEXCode Pro V5 Text Tech Support to PROS Support.

The error message seems like it is coming from the ROSSerial library. Here is a thread where others also got this error message. You may have to adjust your baud rate to meet what is specified here.

I have been learning ROS for my university’s robotics club too, so I am curious how you are planning to use it. I am very interested to hear more!

6 Likes

Thanks for your response! I’ve tried setting the baud rate as it says in the first article, but as far as I can tell the baud rate is set to 57600 for both the vex code and the ros code. I have also tried changing the buffer size in the include directory but that does not seem to fix it either.

The other possibility seems to be starting the node with baud rate 0, and then restarting it with baud rate 57600. Is that just a matter of editing the main.cpp file each time, because I am not sure how that would work procedurally?