Help!!!master code won't download and programs won't run!!! Please help!!!!

OK. Here’s the story. I downloaded a code to my robot, but it didn’t work. It was very simple, just four motors driving forward forever in a while loop that stated “While (1)”. Mark-O thought that the controller might need the master code re-downloaded. I was a little lazy and I didn’t do it until today. So I plug the cable into my robot, and the other end into my laptop. I had the correct port and everything was right. The microcontroller was previously in online-mode in which it worked flawlessly. So, anyway, I turn on the controller and the orange light keeps flashing, which I think indicates that it is in online-mode. I turn on the transmitter. The RX1 light does not go on. I open up Easy-C, select “Build&Download”, and select “Download window…”. The window pops up. I click “Options” and click “Download master code…”. Another window pops up. I double click “Vex” and then double click “Vex_Master_Code_V7” The window closes. The download window prepares to download. Usually, the “not connected…” phrase at the bottom left corner flashes to “Com port is open…” twice, stays at “Com port is open…” and then downloads the program. This time, it said “not connected…” and then stayed at “Com port open…” until a message comes up saying “To enable download, make sure the power is on and…” That’s my problem.

Please help!

Will anything download (and work properly)? Default code, online window code, or a simple program?

We had a situation where we could download a short, simple program but not master code (it seemed the size of the download had something to do with it). We never figured out exactly what the problem was, but it went away when we turned off the computer, allowed it to sit cold overnight, and tried again the next day.

Only the online code worked before I had this problem. Nothing at all downloads. Could it be a problem with the driver?

I’m not much of an expert with these kinds of things, but if you have access to another system and/or Vex kit, I would try the following:

  1. Try downloading using the same computer on a different microcontroller that is known to work.

  2. Try downloading to the same microcontroller using another computer/software setup that is known to work.

Once you’ve isolated whether it’s a computer of microcontroller malfunction, you can troubleshoot further from there.

I can’t do either of those, unfortunately.

I tested it again after restarting my laptop and it still doesn’t work!:(:frowning:

Does anyone have ideas? I’m stumped.

Ok, let me put my $0.02 into this thing. What if you baud rate is really messed up? I had something similar to what you are describing and that was the problem, but I forgot how to fix it. I’m sure that one of the more experienced “vexers” can elaborate on this idea.

lucky you have a laptop!?

What’s a buad rate?

I got a laptop from my family after getting an award in school. It’s an Inspiron, which is pretty good besides the minor Vista issues.

I thought of a few more things to try. Not that they’ll necessarily work, but you might stumble into a solution.

  1. Disconnect the battery from the microcontroller, let it sit for “a while”. Recharge, reconnect & try again. Or another thought is to try using 6 fresh AA batteries in the original battery holder that comes with the Starter Kit. That should provide maximum power.

  2. Try the software on another computer. You can get a 7-day trial version of EasyC at Intelitek’s website:

wow that’s all you had to do to get a laptop? i’ve been getting 100 average for the past 4 years now and i haven’t gotten a thing

I’m letting the battery sit.

My parents gave me it because it was signed by G.W. Bush (Not that he gave me the award, the president of the education department decided that I should get it) and it was for accademic exellence. Only 3 other kids in my school and grade got it.

Help!!! Another problem came up!!! There was a short, causing the microcontroller to stop responding to my laptop. I unplugged everything, redownloaded the master code, and downloaded a very simple program. The robot didn’t do ANYTHING when I ran the program. I tried EVERYTHING! Please! Please! Please! Help!

could it even turn on?

Talk to Vex. Then buy another microcontroller. It’s fried.

Uh-Oh… That’s what I thought. I’ll have to find the short and avoid frying my new controller. I think I blew a chip while testing for the broken sensor. Oh well, now I could possibly need an extra $150. :frowning:

How long is the warrenty? If its 90 days, I have a big problem.