Help needed with Programming Hardware Kit

I am new to VEX Robotics and this forum. Can anyone help me with a problem I’m having when I try to use RobotC to wirelessly program my VEX Clawbot using the Programming Hardware Kit (post 2012 version of the kit)? I keep getting this error message:

      Failed to verify that the serial link is connected to a Robot Controller
      COM Port 'COM8' cannot detect a VEXnet Joystick or VEX Cortex 

Here is what I have already done successfully:

  • Installed the VEXnet Serial USB Driver from the VEX website
  • Used the VEXnet Firmware Upgrade Utility to update the cortex and joystick with latest firmware
  • Used the VEXnet Key 2.0 Firmware Upgrade Utility to update the keys with the latest firmware
  • Paired the joystick with the cortex and then drove then Clawbot wirelessly
  • Installed RobotC Version 4.52 on a laptop running Windows 8.1 Enterprise 32 bit
  • Connected my laptop to the cortex with a USB cable, and then updated the cortex with RobotC firmware
  • Successfully programmed the Clawbot with a RobotC program using a USB cable connecting the laptop to the Cortex

But a problem happens when I plug one end of the Programming Hardware Kit into the USB port of the computer and the other end into the “program” jack on the joystick. When I click “compile and download” in RobotC that’s when I get the above error message. I looked at the COM port settings in RobotC and the COM port appears to be recognizing the Programming Hardware Kit, but not the joystick it’s plugged into.

I made sure the joystick firmware is updated and I tried again with the joystick and cortex turned on and also off, but nothing works. I made sure the cortex and joystick both have keys plugged in. I even installed the Prolific USB driver just in case it was needed (it shouldn’t be because I’m using the newer version of the Wireless Hardware Kit), but that didn’t help.

What should I try next?

Just a dumb try, but check to make sure all ends of the cables are plugged in, including the USB end into the orange “brick” adapter. I’ve known my kit to lose connection just because the USB cable slid out of the brick a little.

Second, try using “Automatic Selection” in the Detailed Preferences menu. Is the recognized port changing numbers every time, as in “COM8” becomes “COMxx”?

Just thinking out loud but does anyone know what firmware the vexnet 2.0 keys come with out of the box? I know an old version of the firmware didn’t support wireless downloading.

If you have white keys try this

http://link.vex.com/downloads/VEXnet-Key-2p0-Update

Edit: Just realized that is one of the steps you already tried, hmmm.

AppleDavidJeans and tabor473,

Thanks for your quick replies. I appreciate your help. I made sure all the connections are tight and used “Automatic Selection” but it still doesn’t work. I also updated the keys.

The “COMxx” number does change every time I plug the orange USB cable into a different USB port on the laptop. I tried all the ports, but I still receive the same error message.

Are your lights all green on the joystick and the cortex before trying to download the program (do you have a solid connection)? The joystick needs to be communicating properly with the cortex to use the programming kit.

When you try and download a program have a look at the green led on the programming adapter, this will let you know if ROBOTC is trying to communicate with the joystick.

Try using a USB A-A cable between cortex and joystick (ie. replace the VEXnet keys with the cable) and see if that works.

Try pressing the button on the programming cable to see if it is able to communicate with the joystick.

Let us know the results.

nnolte,

Thanks for your reply. After I plug in the hardware kit to the laptop and joystick, this is what the lights show…

On joystick: joystick light green; robot light off; vexnet flashing green
On cortex: vexnet flashing green; robot flashing green

jpearman,

Thanks for your reply. When I try to download, the light on the programming adapter is flashing green. I tried pressing the button, but I still got the error message.

I removed the wireless keys and replaced them with a USB cable as you suggested. I still got the same error message, but the motors turned on for a fraction of a second (which did not happen when I tried it with the wireless method). I’m not sure what that means.

Also, I am new to this and I’m using the 10 day trial version of RobotC. Could that be part of the problem?

This means that ROBOTC can successfully talk with the programming cable, it probably rules out any driver problems or things like that.

What I was really interested in is whether the leds on the cortex changed when the button was pushed. The button (which is rarely used) puts the cortex into “program” mode manually, the leds should change on the cortex when this happens. I was interested to see if, independently from ROBOTC, the cable was able to do that.

No, this has no impact.

Check that the connectors on both ends of the flat cable from the programming dongle to the joystick are fully seated. If they are, then my best guess is that you may have a bad cable and need to contact VEX tech support directly.

I also want to check on another couple of things and will post some more thoughts later.

jpearman,

I tried a few more attempts with the USB cable connecting the joystick to the cortex (instead of the keys) and sometimes I got the original error message, but other times I got some new interesting error messages such as:

 Failed to verify that the serial link is connected to a Robot Controller.
 Cannot communicate with VEX Cortex SlaveCPU.
 Master CPU communication is working.

and another time…

 Failed to clear items.
 Failed to download user's program files to robot controller.
 Error 'Failed loading RAM pointers to flash locations.' 

Also, I made sure all the cable ends were fully seated and then pushed the button, but it did not change any of the lights on the cortex.

This message means that ROBOTC could start communications but that the ROBOTC firmware was either not returning status or is not installed. Try doing a ‘software inspection’ (perhaps a few times until you get something useful) and post the results. (robot menu->advanced->software inspection)

I tried the Software Inspection several times and got these results:

RESULT #1

Communications Link: COM Port ‘COM8’ to VEXNET Joystick

Standard Firmware File Names:

VEXNET Joystick: .\Firmware\JOY_V4_25.BIN
VEX Cortex Master CPU Firmware: .\Firmware\CORTEX_V4_25.BIN
VEX Cortex CPU Firmware: .\Firmware\VEX_Cortex_1052.hex

VEXnet Joystick Integrity:

Firmware Version: 4.25 Up to Date
Battery Voltage: 7.3V Good (>7.1V)
Radio Type: RaLink
Calibrated: No
Joystick State: Powering Up

Cortex Master CPU Integrity: Value Status

Data not available

Cortex User CPU Integrity: Value Status

Data not available.

RESULT #2

Communications Link: COM Port ‘COM8’ to VEXNET Joystick

Standard Firmware File Names:

VEXNET Joystick: .\Firmware\JOY_V4_25.BIN
VEX Cortex Master CPU Firmware: .\Firmware\CORTEX_V4_25.BIN
VEX Cortex CPU Firmware: .\Firmware\VEX_Cortex_1052.hex

Cannot Communicate with VEXNET Joystick via COM Port:

The VEXNET Joystick will only respond when it has a working communications
link to VEX Controller. This can either be a Wi-FI link or a tethered connection.
You must first get a link operational to run the software inspection command.

  1. Check VEXNET Joystick powered on.
  2. Check Cortex Controller powered on.
  3. Check VEXNET Joystick VEXNET link (green LED) is operational.
  4. Check Cortex Controller VEXNET link (green LED) is operational.
  5. Check Cortex Controller is not in bootload mode. If so Master firmware may need to be reloaded.
  6. Check battery levels.

Well, you managed to a message to and from the joystick at least once but never the cortex. Was this using the USB cable between the two or VEXnet keys? My best guess is still a problem with the 6pin flat cable from the programming dongle to the joystick.

I did the software inspection with a USB cable connecting the joystick to the cortex.

What do you think is the best way to contact VEX Tech Support about the 6 pin flat cable? Phone, email, another forum, etc?

Thank you for all your help.

jpearman,

Your diagnosis was correct. I found another 6 pin flat cable and everything started working correctly. Now I just need to contact VEX about a replacement cable.

Thank you!

Email VEX support at support@vexrobotics.com and I’m sure they will be able to help you. You can quote this thread if necessary.

I’m resurrecting an old thread. I have a similar issue coming up. I couldn’t find the 6p flat cable, so I used a standard 6p phone cord. I"m getting the same errors. I’m guessing the phone cable is the culprit, as it was above.
my question - is there a pinout for the cable? Is it just straight through or are there cris-crosses somewhere? I would like to get wireless to the cortex running. If I can make up a cable (I have connectors and a crimper) this could happen quicker.