HELP! potentiometer quit working

Can anyone please help me! My potentiometer was working, then quit working all of a sudden. I am using easyC4.

It will read the values in the graphics, but it does not respond to the command . I have tried 3 different potentiometers, and a different cable port. Have the value set at 33.

Thanks for any suggestions!

I don’t get it, the pot is just a sensor, you NEVER set it a value or give it a command, you always read it’s value, that’s it.

So setup an analog input and set that port’s value to an integer, then (if you want) print it to the terminal, or make it drive a servo or something.

The only thing you need to be aware of is that the pot cannot be continuously rotated, it has a range.


No, this is a simple program to stop an arm movement when the pot reaches a given value.

It has worked flawlessly for months and now it stopped. We have changed the pot out three times with same results. Changed ports and extension cables.

When programmed to show in the graphics display the readings seem to be fine and consistent? The controller sees the pot but doesn’t react to it. We have another pot on the robot and it works fine?

You’ve replaced all the hardware and still have the same symptoms. I’d say at this point you need to carefully examine your code. Good luck.

I would have to agree. Check your software. If you can’t find the problem/problems, post it here and have the community look at it. There are plenty of good software engineers here to help you. :slight_smile:


thanks, I will have to wait til I get home, thanks for all the help and support.
Maybe I have overlooked something, hope it is a simple fix.

Thanks everyone, got it working again, was a program mistake that I overlooked

It’s always a software problem except when it’s a hardware problem. But usually it’s a battery problem.

Well said…

We play the blame game. If it doesn’t work the mechanical team blames electrical, electrical then blames the programmers and the programmers almost always blame mechanical.


It’s always a hardware problem! And if it’s not, then semicolons can be considered hardware right?

Wow, definitely an awesome quote!