Help - Programing in OSX

I have been programing in VMWare on RobotC for the past couple of weeks now but I haven’t been able to upload any code to the cortex.

Here are the facts:
-I’m running RobotC 4.32
-I’m running VMWare Fusion 7
-I’m on OSX 10.10.2

I have also tried all of the things in the threads below with no success.
https://vexforum.com/t/mac-osx-cortex-usb-driver/24546/1
https://vexforum.com/showthread.php?p=382774#post382774
https://vexforum.com/t/programming-under-osx/24441/1

Thanks!

Either Bootcamp, or using the A-A Cable should save you!

What does the Cortex appear as in the VM’s Windows Device Manager while plugged in and turned on? Also, what issues specifically are you encountering when you attempt to download firmware/code to the robot? The more detailed information you are able to provide on this issue, the better we will be able to assist you.

Thanks in advance!

Did it ever work?
Did it work before the upgrade to V4.32?
Are you trying to use the programing kit through the joystick or the USB A-A cable? I have never tested the USB A-A cable driver under 10.10 but it should work.
Is the ROBOTC firmware correctly installed?
Does it work if you manually select the com port in ROBOTC rather than have it set automatically?

Please note, master firmware update does not work (ie. the vex firmware, V4.25 etc.) from a VM on a Mac.

I have tried using the programing kit and A-A cables.
It has never worked.

The only thing that shows up is when I plug the serial cable in is a device called “USB Controller” it shows up under devices. Windows says that the device doesn’t have the proper driver, but after letting windows search for it for around 6 hours it didn’t turn up with anything. I also tried re-downloading the drivers from the RobotC homepage but that didn’t work either.

Thanks!

Which version of windows? It sounds like the driver did not get loaded (forget what I said about the driver before, that’s irrelevant, spaced out for a moment). Could be an issue with driver signing, perhaps search the forum on instructions on how to install with signing disabled).

New or old programming kit ?

So I disabled verification for signing and re-installed the “Usb-to-Serial”
Still no success.
So I went to install the other driver listed on the homepage “Vex Programming Driver” and I got an odd error. I screen shoted it and attached it.

I’m using the old programing kit.
ErrorWithInstall.jpg

The old programming kit uses the prolific driver, there are some known issues, see this thread and perhaps check the driver version against this list and report back to us.
prolific serial drivers and bad cables

Thanks for the help. I have it up and running now. :smiley:

The drivers on this page are very helpful.
I’m able to connect in RobotC, PROS and EasyC as well.

That’s good news, yes, everyone uses the same driver for communication.