Help! Robot won't work!

The power comes on for the controller and robot. The Rx1 light won’t come on and the orange light that blinks every now and then doesn’t work either. Only lights that come on are the program status light and power light, that’s it. It worked a few months ago, the only thing that happened was that it twitched for a moment. Help!:confused:

so did you load a program and forget to put in default code?
the orange light: do you have a sensor in 9 or 10 slot?

make sure your batteries are charged up and that the cables are all plugged into the right ports
i can’t really see how your program light could be on unless you did some editing to a code and turned it off while you were downloading a .hex file or that you have a cable plugged into the port

Always try doing a search when you are having a problem and you may be able to find your solution. By doing a search on “programming light always on” would lead you to this post:

I do not have a programming kit, and I followed the instructions correctly, I don’t know what is wrong.

maybe the guys at the factory forgot to download the default code and have ome test code in?:confused:

It worked a couple months ago just fine, now it doesn’t work.

did you hit it on something?

Nope, not at all.

R/X recever cable in? sesroe mest up? radio crystals in all the way?

Checked all of that, everything is plugged in.

How could you have followed the reprogramming instructions if you “do not have a programming kit” ???

I have had identical system error several times on several different VEXtrollers. In every case, completely re-flashing the system (including running the master code update) fixed the error.

~ Christopher

I can’t follow the “reprogramming instructions” because I don’t have the programming kit. I never said I followed the “reprogramming instructions”.

That would imply that you followed the instructions which RT posted. While I do not work for VEX in any way, shape or form, this really does sound like a problem which needs to be fixed by running the master code updater/re-installer.

If you follow the link which RT posted, you will notice that one of the answers is:

The fact that you got an answer from the official vex source would tend to imply that you do, in fact, know what is wrong.

~ Christopher

Dang, you sound like a lawyer, I think I’ll just buy a programming kit and just reprogram it. Thanks for the help!

Doesn’t the orange light on the robot usually mean it’s receiving a transmission from the controller. My orange light doesn’t come on until I turn the controller on. The book does mention to turn the robot on first, then turn on the controller after. Or make sure your crystal numbers match on robot and controller.

I am now having a similar problem as Carjacker. All has worked ok for a while
(operated under both radio and programmed control) but showed intermittent
interference on the radio control and now the radio link and rx light
doesn’t work at all (tether operation still works fine). I checked out the
crystals and both are marked frequency 61. I tested both with a frequency
counter: the transmitter crystal gave a steady frequency of 75.419Mhz
(correct according to the manual = 75.41Mhz) and the receiver crystal
75.8656Mhz which seems to be way off. Could the wrong crystal been placed in
a different frequency housing?? or maybe the receiver needs retuning?

IIRC in the 11 Meter Citizen Band (CB) Radio the Receive Crystal was a lower Frequency than the Transmit Crystal.
This MASTR II Crystal Frequency Calculations page would indicate that the Transmit and Receive Frequencies are different and vary up or down by what frequency range they are in (Vex is in the 75Mhz range, re: The Futaba Radio Frequency Chart)

I would suspect an Issue with the Crystal, since that can happen… Trying another Transmitter/Receiver pair to verify RF opperation with you Vex Controller, then swapping the crystals would be the next step, unless IFI will just replace them Out-Right…

Someone recently just pointed out how “noisy” the Vex Transmitter is… I need to find that link…

How about making sure ur batteries r putting out enough voltage to run the bot by putting them in the remote. if they r bellow 10 volts do the method in the binder of draining them and recharging them. also try using alkalizes batteries.


Thanks Marco. I’ll try out a different pair of crystals. Battery voltage was all fine