Help with Clawbot IQ or maybe controller?

We are very new to VEX IQ. We built the standard base drive and it worked perfectly. The kids had a great time driving around with the controller. Onward to the Clawbot IQ. We built it the left side works perfectly but we cannot get the right side to work. We have checked the connections several times , even dismantled twice. When we spin the tires we can hear the gears turning, sounds the same on both sides. I checked for updates and all motors and sensors are updated and connected. I think it is the controller’s right side, none of the buttons will work. All troubleshooting suggests are appreciated. I meet with the kids again tomorrow in the afternoon. Thanks

The first thing I would do is listen to see if the motor is turning. If you can hear the motor when you push the joystick forward then the shaft has come out of the motor.

The easiest way to get it back in is to have one person push the shaft in (better for an adult) while someone else slowly pushed the controller forward. When the squares line up, the shaft will slide into place. If you use the side of a beam to push it in that will save you some pain on your hand as well.

If the shafts keep coming out, make sure the are using the shaft collars (black round rubber things) to keep the shafts in place. Otherwise, they will slide out over time.

Let us know if it’s something else. I’m only confused about the work “button,” so which button or stick exactly you are using would be helpful in helping.

Best of luck!

For the troubleshooting, you can easily eliminate the controller from the equation too. You can use the “Device Info” feature on the brain. Go to Setting screen (by pressing ‘X’ button), then select ‘Device Info’. There, you can scroll through all your ports to see the attached devices to verify if the brain sees them. For motors, you can actually test them - turn off and on by pressing the checkmark button when selected. If you hear the motor turning when started from the device info, you know it is OK. If the wheels turn too, you know your shaft connection is fine as well.

As for the controller, you can run the ‘Driver Control’ function, and when running, press the down arrow on the brain - it will show you the state of all the joystick controls and you can verify whether the brain receives all the signals correctly.

Thank you for the help. I was able to locate the problem, Port 6 is empty but there should be a motor recognized. I changed out the cable, nothing. Does this mean the motor might be bad? It is only the third use. And like I said earlier, when we built the base drive the motors worked. Any suggestions? I have thought about changing the motors out to help rule out possible connection issues and not motor issue. Doing that now.

Well…bad news it looks like there is a problem with the motor. It is not being recognized. Have to figure out what to do next. Need to have 3 motors
thanks for all of your help.

Sr Sue,

One suggestion is to attempt to restore the bricked (dead) motor by downloading the firmware into the suspect motor while connected to port# 1 per this video, make sure no other motors/ sensors are connected while you perform the download. You may also execute a right on the icon of the brain, and select “Detect Device Port 1”

If this fails we will need to replace the motor under warranty, just send an email to for further details.

Detect Device Port 1.png