Help with IME's

Hi everyone,

We have been using 4 IME’s on our x-drive all season long and they have worked well for us. About a month ago as we were preparing for state, the IME’s stopped working as we were practicing. The light on the IME’s turned solid yellow/orange and the IME’s would not count up or down as we drove. We checked the wiring, tried updating firmware, we even changed cortexes, but it did not fix the issue.

We then checked each IME individually by plugging it directly into the cortex. When we did this, only one of them turned green and worked when we drove the robot. So we concluded that the other 3 IME’s broke some how and we decided to just use 1 for state.

As we are preparing for Worlds, we decided to go back to using 4 IME’s. We bought 4 more and replaced all of them except the one that was functioning perfectly. When we turned on the robot after installing the new IME’s the light on the encoders went back to yellow/orange and the encoders will not count.

We are fairly certain the issue is not in the wiring, the code, the cortex, or in the sensor itself, so we are not sure what can possibly be the issue.

If anyone has had a similar problem or knows how I can fix this, your help would be greatly appreciated.


I don’t know what’s wrong, but this is the exact same thing that happened to us at the US Open and we are still trying to figure it out so any help would be appreciated from us as well.

There are only so many things can cause these issues. My order of most likely.

  1. bad cable(s)
  2. bad IME(s)
  3. code
  4. Power
  5. bad cortex

If an IME has the led illuminated (any color) then power is probably good. If the led is green (flashing once or twice) then communication is probably good.

Are you using ROBOTC or EasyC? Debugging is easier with ROBOTC.

Test each IME in turn with the cortex, create a simple program, turn the motor by hand and watch for encoder counts, do any work? If not change the 4-wire cable and test again.

When you have at least one working IME, add a second, does that work? If not change the cable from first to second, does that now work? If not change the first IME (perhaps a loop through issue).

Continue with third and fourth ones.

Some tips.
Keep cables short, several cables from cortex to IME or between each one is not a good idea.
use simple test code and the debug facilities, ROBOTC debugger or printToScreen in EasyC, don’t use the full competition code.

Let me know how you get on.

Thanks jpearman for your input. We’re using RobotC. Update on our situation:

We are actually using 5 IMEs (four on the base and one on our intake). We messed with the wiring a little and our situation is better now. When all 5 encoders are plugged in the first 3 are blinking green, but the last 2 are solid yellow. If we just plug in just the last 2, then both of them blink green, so those 2 encoders are definitely good. We have also confirmed that the wire from the third to the fourth and the fourth to the fifth are functional.

Could any issues arise from adding extra encoders? I know the cortex is supposed to handle up to 8, but is having more than a certain number a bad idea? We previously ran 4 consistently problem free (until recent obviously).

No problem running more than 4, I’ve had 5 on the “open source robot” for a couple of years now.

How long are the cables between the IMEs, just a single 12" run or multiple cables strung together? Are you sure the cable is pushed well into the IME, sometimes they can take a little force to push in.

What happens if you go skip the third IME and go from IME 2 to IME 4?

We have 2 12" extensions between each of the first four encoders, and then the fifth one is on the intake at the top of our lift so we actually have about 7 feet of extensions going up to that one.

When we go straight from number 2 to number 4, number 4 doesn’t work, but 1 and 2 still do.

We also tried going straight from 2 to 5, and when we did that number 5 doesn’t work.

That’s a lot of cable (over 15’), if you leave off IME 5 (the one at the end of that 7’ cable) do the first 4 work?

A minute ago, the first 3 worked, but the fourth didn’t. However, we just power cycled the robot, and now the first four all work. When we plug the fifth in, it doesn’t work, but the first four still do.

Is the light on the 5th still solid yellow when you plug it in?

Try to skip the whole length of wiring up the lift, when the lift is down use 1 or 2 extensions to connect it to the previous one. That way you can know if there might be issues due to the length of the wiring.

All five of our encoders are now working. We honestly didn’t change anything from a few hours ago (besides unplugging and replugging to test all of the IME’s) and now everything is functional :confused:. I have no idea what was going on, but from my experience the IME’s can be pretty temperamental.

Thanks everyone for your advice.

Glad you have it working. I think you are near the limit (or perhaps beyond) on cable length and small differences in the quality (ie. the resistance) of the connections may be the difference. Anyway, good luck next week.