Help with motor update

I need to know if I’m doing something wrong or I have a bad motor…

My students assembled the Claw bot from the manual I double check the wiring/construction and everything is correct, but one of the motors will not work. We tried different wires and different ports to try and get the motor to run. I then downloaded the Firmware update tool plugged in everything, but the program only recognizes 3 of the 4 motors (see image).
I tried the following things with no luck

-change the port
-plug in only the bad motor
-plug in the bad motor to port one
-turn on/off the robot (100 times)
-try to update specific port (software will not let me)
-restore brain firmware then update again
-unplug from computer and plug brain back in
-reinstall software
*I had admin rights on the computer

I had this problem with other kits and after about 40 times of turning on/off plugging/unplugging I finally worked

Any advice?

Nashb1,

Please update the “suspect” motor using port#1 in your brain, make sure no other motors/sensors are connected to the brain.

Let me know your results.

​-Eli

When I attach the “suspect” motor to port 1 the software says no motors connected…

Nashb1,

It looks like you will have to mail back the motor for further analysis, please contact [email protected] for instructions.
Regards.

-Eli