How to stop startup sound.

We have a speaker installed on the robot but really don’t like that it beeps every time it turns on. Can this be changed from one of the #competitionincludes background codes?


I don’t think the speaker beeping on startup should be a big concern, and it’s a good confirmation that the speaker’s working. :slight_smile: And to answer your question, I’m not 10% sure, but believe that the beeping is part of the Cortex firmware’s startup procedure before it even reaches the user code, so it’s not possible to get rid of it.

I don’t remember having any startup beeps when we were using the speaker with Convex last year, so I don’t think this is the case.

The ROBOTC virtual machine plays a sound on the speaker when it starts up, this can not be disabled with the current firmware.

ConVEX does not play any sounds when it starts.

Or just unplug the speaker… I remember how last year I had a speaker and I drove everyone crazy because it was so loud each time it turned on. Not to mention that it restarted whenever VEXnet disconnected, which happened a lot…