How to use 4 motors for drivetrain

I’m trying to make a drivetrain with 4 motors but I don’t know how to make it use all 4 motors. Right now it’s only powering the back wheels. I tried to download the 4 motor drive from Vexcode but that didn’t work. How can I connect all 4 motors to the drive?

If your using code blocks you can do something like this. Note that this is for a 6motor drive so you just have to remove a motors form the left and right sides of your code. You also have to set all of the motor ports up individually not using any preset drivetrains that code blocks might have.

2 Likes

Thank you I probably won’t be able to test it until tuesday so i’ll update when i can

I assume you’re using VEXCode. You can use the 4 motor drivetrain in the setup. Add Device → 4 motor drivetrain. Then select the correct ports.

2 Likes

When i tried it i downloaded it to the brain and it still only powered the back 2

correct ports? plugged in all the way? sometimes loose. If not, maybe the cables themselves are bad. If not, maybe the ports themselves are bad.

3 Likes

Yes, I forward the notion that the drivetrain feature (when the 4 motor version is selected) should be powering all 4 motors.

  • Double check your ports by opening the program, devices, and your drivetrain.
  • If there is nothing wrong there, try swapping the ports - tether the drive motors that didn’t work to the ports that did, and the drive motors that did work to the ports that did not. This should tell you if there is a problem in the brain/ports/programming or in the motors/cables/wiring.
2 Likes

I’ll try that when I get to the robot. What I did was connect the brain to the computer select add a device, add a 4 motor drive, and used ports 1234 for the 4 motors and download it. Is there anything that I needed to do other than that

1 Like

Make sure you are opening your program when you start it, and not selecting “drive”. This a problem that’s easy to forget about. The default program slot is slot 1. This can be changed at the top of the block code page near the center.

5 Likes

That might actually be the issue because I just selected drive and didn’t select a program

1 Like

Fantastic! That would be your issue. So many people come to me asking why the robots don’t do anything, and it’s always because they select “drive” instead of selecting a program.

1 Like

It did work thank you all for your help

Make sure that when you start running the code on the controller you select the program and aren’t just pressing drive.

Edit: Just saw the rest of the posts and it looks like that was the issue and its working now

1 Like

Here’s another tip:
When programming, make sure you know the difference between the “when started” and “when driver control” blocks.

1 Like