I am getting an error when updating the brains firmware

Screen Shot 2020-10-09 at 3.05.49 PM
It says update error. What does that mean and how do I fix it? @jpearman?

I’ve had that…you should get comfortable with the idea that you will need to spend time troubleshooting vex’s products.

Unplug the brain from the battery and try again. That worked for me. I had to fiddle with it a couple of times. If you want an “official” answer wait for james but my guess is he says something similar

just try restarting everything. computer, power cycle the brain, try with different usb ports/cables. all the generic troubleshooting things.

2 Likes

check you don’t have any other VEX programs open that may be trying to communicate with the V5. If you can’t get VEXcode to do the update, try the standalone firmware updater from here
https://www.vexrobotics.com/v5/products/firmware

also, make sure you have internet, we pull the firmware from a VEX server.

2 Likes

Ah internet is one I didn’t know of. Last time I had the error I was in my basement where the signal is weaker. I’ll have to keep that in mind. Thank you for wisdom :relieved:

I fixed this some time ago but I guess I will post my answer. I downloaded the vex firmware updater and that didn’t work. It said it wan’t connected to the brain but I check usb connections and the brain was connected. I ended up downloading vex code(the blocks) and updating through that it for some reason it worked.