I cant download programming

So, today i was maded the programming for my robot, and when i tried to download it, the icon of download doesnt turn green, i also tried on VexOS, and the brain wasnt detected, i tried to change brain, baterry, cable, blocks/code, and pc, and nothing works for me :frowning:
Note: im using VexCodeIQ v2.2.7

Are you using a Windows machine? If so, make sure the VEX drivers are properly installed.

I also noticed VexCodeIQ v2.2.7? Isn’t that an old version? I think a new version 2.4 was released last month?

Make sure the sync cord you are using is a data cord and not only a charging cord.

I agree that you should check that your cord is a data cord and that it is working. If you have another, try swapping them out. Cords are often finicky. Also, if it is a school computer, it may not let your code compile (which it needs to do before uploading) due to the anti-virus used by your school. Have you successfully uploaded code from this computer before?

yeah, but when i try 2 add an device, the programming makes weirdo

OK, let’s get some basic information. What sort of computer/laptop are you using? Did you update your version of VexCode?

im using an pc of 64 bits w windows 10, my currently version is 2.2.2-7


1: re-installing Windows drivers. See the article on the vexrobotics.com site under support, path Vex Library/Vexcode IQ/ [Installing the VEX Devices Driver Installer for VEX IQ. Alternatively, you should be able to find it here: https://kb.vex.com/hc/en-us/articles/9684176193428-Installing-the-VEX-Devices-Driver-Installer-for-VEX-IQ.

  1. update VexCodeIQ to current version (I think it is 2.4.4-10)

Is there a reason why you are still using Win 10?

Windows 10 still works fine. Many computers are not supported by Windows 11 but will run Vex programs just fine. I have some I3 (not supported by Windows 11); I5 (Windows 11), and several I5 (Windows 10) and I7 (Windows 10). All run the Vex IQ programs fine.

Not to side track this conversation but there are millions of systems like Rod said out there that don’t run windows 11. I have 3.6 GHz 16 Mb mem, 750gGb disk that runs all of my CAD applications. Frankly, I’m happy that it doesn’t run Windows 11 because that has turned into an advertising / app nightmare.

To the ops problem, I’ll bet a USB cable that is charge only (no data wires) or locked out USB ports because of a school issue.

Agree. Just trying to determine some facts.

I had this exact problem with a couple of Win 10 machines at Worlds last year. Took it to the VEX guys and, indeed, the problem was with the drivers and a driver re-install fixed the problem. Not sure the problem has anything to do with OS version although I’ve not had any issue with a couple of my Win 11 machines.

I can see driver installs being a problem, drivers are the bane of my existence for some hardware.

I currently run an old XP laptop and a Windows 7 laptop because drivers for some hardware I own will not install on later versions. But in recent history I’ve seen more of an issue with the $3 USB cables that people buy online. They are cheap because they only have the power lines, none of the data lines.

But if it’s not the cable then a reinstall of the drivers. School laptops are a mess since the IT departments lock them down tight, even to the point of Chromebooks not letting you install extensions without IT intervention. (Not knocking them here, I’d do the same thing. But it’s hard when the teachers don’t understand why stuff doesn’t work)

1 Like