IME Disconnects after a Few Seconds

I have a problem with the second (out of two) IME that I am using. I am using a temporary way of connecting it which consists of a 3-wire extension and breadboard jumpers because I do not currently have enough 4-wire extensions. I do not think this is the issue however as the IME does seem to connect properly for the first few seconds (2 blinks), and that it worked fine earlier on in the day. Now however after a few seconds of seeming to work it says it has disconnected (2 “blips”). Any Ideas?

I probably won’t be able to help you, but this might help other people trying to help you.

Do you have the same problem if you switch the IMEs? That is, if you connect the disconnecting one directly to the cortex.

I am unable to switch the IMEs right now because of time and difficulty. However I did try connecting the problematic IME directly to the cortex (but was unable to reach a cable to the working IME), and it worked.

I may be entirely wrong, but I am inclined to think this is somehow related to the differences in conductor (cable) type between the VEX wires and your temporary solution. Based on this post, it seems as though such a seemingly insignificant difference may actually make a huge difference for the IMEs (and anything running on I2C).

Also, double-check your programming and consider posting or PMing your code for the community to double-check it.

Plug the 3-wire extension in so that signal and address lines go through the VEX extension. Use the breadboard jumper for the ground (black) wire.

Note that when configured this way the power (red) wire will also go through the VEX extension; I didn’t mention it because capacitive loading on it is less significant than on the signal and address lines.