IME Shows solid red LED and always reads zero

We are using IME’s on our robot this year
the IME that is not working is the second one down the I2C chain. the first motor in the chain is working properly, but the second one is not.
the IME that is not working shows a solid red LED at all times. The VEX product page explains that this means “data is being written to EEprom (1sec)”
EEprom is 'Electrically Erasable Programmable Read-Only Memory"
so it seems to me the error here is that the robot is trying to write to read only memory and that is causing an error. Any one know how to fix this?

Have you tried to unplug the IME to the I2C port and then restart the cortex. If this doesn’t solve it I would wipe the cortex and restore it then install the firmware back to the cortex.

i have tried restarting and unplugging, it didn’t do anything to help, I re-downloaded the firmware, now the red LED is gone, and now it gives a green double blink or blip every couple seconds, but the encoder still always reads zero.
from the vex product page
“Green Double Blink - initialized, valid I2C communications, in neutral and terminated”
“Green Double Blip - I2C communications lost, initialized, neutral and terminated”

any one know what might be going on?

Have you tried making it the only IME and not second in the chain? That would tell you if it was a good IME at all.

Are both IME’s assigned in the motor configuration tab?