Inertial Sensor Not returning Data At All


I’m having an issue with the inertial sensor where I can’t receive any data. I have it so it is initializing in pre_auton and printing the heading and yaw to the screen during driver control. Am I missing some step? Should I send code?

First of all, on your V5 brain go onto devices and tap the internal sensor. Rotate the sensor or robot and see if any values change. If a value changes, it is likely a coding and not hardware problem and it would be appreciated if you can paste your code here so we can help you troubleshoot. :slight_smile:

1 Like

Is the brain full updated to vexos 1.0.9 ?


Try using a regular gyro the 3 wire port is better.

How do I check what the os of the brain is or does it automatically update? Also, the values did change on my brain screen in the device menu. My code is below.`

wait(10, msec);

and then

I tried heading and yaw and both displayed nothing on the brain screen.

If you plug your brain into your computer, you can check what os the brain is on. Btw this isn’t who you think it is.

On the Brain, tap the devices icon, then tap the device that looks like the Brain. The version of VEXos will be displayed.

Can I ask you to put some facts up about that? I’ve done some testing with both and the new sensor is much better than the 3 wire around drift across the 2 mins.

So who are you if you are not who we think you are?


Well 3 wire ports have 3 wires while the v5 cables have one. And the 3 wire ports have more ports then the v5 cables do because it must support all 3 wires. 3>1 so 3 wire is best. And I am Marcus

Where did you get 1 from?


This looks like 1 to me.

1 Like

If you strip the black cable, you get 4 cables. It is 3 cables. Look near the connector. There is green, black, blue, and yellow

1 Like

Hi Marcus!

RoboKnight has solved the cable issue. If you were (don’t do this at home) open up the new sensor, you’ll find that it has a better sensitivity and drift numbers than the old sensor.

1 Like

I am sorry. This should be

I don’t know what I was thinking, because the previous sentence says 4…