Installed wrong firmware update

I accidentally updated the firmware to 1.16 using the Smart Radio setting, not realizing that we don’t actually have the Smart Radio. (Oops, we are new to this!) Now the controller will not pair wirelessly to the brain. I followed instructions to restore the firmware back down to 1.15, but wireless pairing still doesn’t work. Both radios are firmly clicked into place, and they paired successfully before I initiated the wrong software update. Everything is new, out of the box. We haven’t done any programming yet. Does anyone know how to fix this?

There is also firmware on the joystick controller. This is updated using the same VEX IQ Firmware update tool while the joystick controller is connected with the tether cable to the brain.

A couple of notes:

  • If you update the brain to version 1.16, the joystick controller also needs to be updated otherwise they won't connect.
  • If the brain and joystick controller are updated to 1.16 (and corresponding controller update) they should still connect with the regular 900 MHz radios.
  • After running the VEX IQ Firmware update, it might be necessary to re-tether the brain and joystick controller with the tether cable before trying to connect wirelessly.

Thanks for the reply! The brain and controller were updated to 1.16/1.05 at the same time, and are now running 1.15/1.04. Still no success. I’ve tried to re-tether with the blue cable several times. To do that I turn both off, plug in tether on both, turn on brain, see tether symbol, unplug tether from both, turn off both, turn on both. Just says “searching”.

I just updated all components to the Smart Radio 1.16/1.05 firmware, and then back down to the ROBOTC 1.15/1.04. The controller and brain are now successfully paired wirelessly, hooray! Still doesn’t drive forward, but I wrote about that problem in a different thread. One problem solved, thank you!

I see in a later post that you have fixed the link problem, but I did want to add that if the tether process worked but the radios don’t link, you should start with radio issues. The Brain and Controller can see each other, so the problem has to be in the radio link. I would, 1. make sure the radios are inserted all the way, 2. try swapping out ONE radio with a different one, 3. try swapping out the other radio.

Good luck!