Issue Connecting through Wireless Vexnet keys

Hello everyone,

I was working with some robots and noticed an odd issue. My robot is having issues connecting via the controller to the cortex using the vexnet keys. Here’s the setup: robot loses connection with about 2 ft of distance from the robot.

Things I have tried: updating firmware for all three parts (keys, cortex, controller), replaced batteries, replaced tether for pairing. I also replaced controllers and vexnet keys as well. At this point I am thinking this is a cortex issue and I will continue to investigate but I was curious if anyone had run into their issue and possibly had a solution.

Future attempts I will make:
-Think it is a cortex issue, will go through inventory and see if this problem exists elsewhere
-Run as vexcompetition communication platform rather than vexnet/usb, even though the latter has worked fine in the past

Links in the forum I have already read and went through with no solution yet:

Any help is welcome.

Have you tried a USB extender cable? The USB slot in the cortex or the joystick could have a bent side making the connection not great.

Tried that and other things as well. To be honest I fixed the issue but it was an odd solution. I ended up switching the vex keys out. However, when I attempted to run the programs again with the original vex keys, problem fixed.

I have been removing vex keys that I find problematic (even temporary) and will test them again later on.