Issue with Port 10 on Cortex

I am experiencing an issue with two Cortexes of mine where the motor on Port 10 will only move when assigned a negative value. I run the following code on the Cortex:


task main() {
    while(true)
      motor[port10] = 127; // Or any positive value   
}

and the motor does not move. If a negative value is assigned, the motor works fine.

I am able to consistently reproduce this issue:

  1. Manually flash Master CPU firmware v3.23 onto Cortex
  2. Manually flash RobotC firmware v0955 onto the Cortex
  3. Unplug everything from the Cortex except a battery
  4. Plug a motor into Port 10
  5. Download the code shown above
  6. Watch nothing happen
  7. Change the code above to use a negative value
  8. Watch motor move

I have tried this procedure on two separate computers with three cortexes, using multiple motors. Two of the three cortexes exhibit the issue. All computers are running RobotC 3.54.

The issue first appeared during a competition of ours (which I personally did not attend), where our conveyor belt was only moving in one direction. Afterwards, I pinpointed the cortex as the source of the issue, as was motivated to test two others.

I have heard of ports being fried, but not from too much load. I thought it was weird that the ports can still move a motor in one direction. Has this issue been seen before? Is it a hardware or software issue?

Any ideas would be appreciated.

conradev,

Is this issue present on the 3rd Cortex?
If not, then you may have a damaged motor port 10 on the other units.

-Eli

The third Cortex does not experience the issue.

The two Cortexes with dysfunctional ports do seem to be damaged, and in the same way. Here is the top and bottom of one of the boards. The chip looks and smells fried.

Do Cortexes come with a a warranty? If so, for how long does it last?

For the time being, I will have to use a Y cable.

conradev,

VEX products have a 90-Day Warranty.
If you are still within warranty please send an email to support@VEXrobotics.com
If not, using a Y-cable will be an acceptable solution.

_Eli