Issues With 393 Motors

Hi, I searched for info on the same issue, but couldn’t find anything, so I’ll be posting here. I’m currently working on a project involving Vex and Easy C. I have two 269 two-wire motors, four servos and two 393 two-wire motors. I’m having issues with the 393s and I’m not quite sure what could be causing this. Two were purchased around a month ago and I’m not sure when we got the third. Just running them through a test code, I found that using a 2-3 wire converter they turn counterclockwise for maybe 250 milliseconds before following any instruction in the code. The direction is always counterclockwise (unless the polarity is reversed) no matter what direction the motor is supposed to be driving in and is followed by the correct motion. When plugged directly into the motor ports of the cortex, they just stutter and don’t work at all. The 269 motors work fine with the same code, both using the 2-3 wire converter and plugged directly into the cortex. I don’t believe that they are damaged since the behavior is consistent and I believe it has been happening since I got them, so I assume there is something I either need to change in the code or wiring and would like advice on this. I can definitely switch the drag and drop block system of Easy C to the actual code and make edits to that if it’s necessary in this case.

I was just testing out the motors again and I figured out that they run normally while the cortex is still connected to the computer by a USB cord, but they have the issues described above as soon as I unplug the cortex. I have no idea how to solve this issue or why it would work in one case and not the other, but advice would be greatly appreciated.

There is no programming difference between 269 and 393 motors, so there is no magic code to change. If every word in your description is accurate, I suspect the 393s must be defective. But since this is your first post, it may be your description instead.
Here are some ideas to try:
Try using the online window to control the motor ports directly, and hot swap the 269 and 393 motors to the same port you are controlling to see if they act the same.
Try Disassembling the 393 gear box and look for broken teeth on the gears.
Make the simplest possible example code that demonstrates the problem, by driving two motor ports the same: plug in one 269 and one 393, they should do the same thing. Post your code here, and the description of what each motor does.

Thanks for the reply! I just added an update to my first post that you may want to check out. I tried your advice of using the simplest code possible (just running the motor endlessly at full speed) and checking both a 393 and a 269 in the same port. The 269 ran normally and the 393 just stuttered. I also ran them using the online window with the cortex plugged in and this time they both ran normally. I’m unsure about there being an actual issue with the 393s since they were bought at different times and all have been used very little, but it’s possible. I’d like to rule out all other possibilities however before trying to disassemble these motors. With the new information I added to the first post, is it possible that an issue with our cortex is causing this?

What is it you are plugging the cortex into, USB cable to computer?
Do you have a fully charged 7.2v 3000mAH “main” battery plugged in, and the cortex power switch is on? (not just a 9v battery in the backup power port)
If the 393 and 269 are plugged into the same port, are you using a Y cable? If so, both motors have to do the same thing.
Motors can stutter if given alternate stop/go commands from bad code.
Motors can stutter if they are power limited by PTC fuse, but that is more of a stop for a second, start up again thing, slower than I would call a ‘stutter’.
Motors commonly jerk once during power-on-reset when cortex power is switched on.
Motors can stutter if the battery is low, and heavily loaded motor crashes the power rail and resets the cortex, so that it starts over. If this were the cause, USB power might keep the cortex running better. If this were the cause, and motor port 1 and port 10 were programmed the same way, and 269 in port 1 and 393 in port 10, then both motors should stutter at the same time.

Yes, it’s USB cable to computer. I’m using a battery pack of six AA batteries, but according to the download window on EasyC it has 7.45 volts. I did not run them from the same port at the same time, I just removed one and plugged the other into the same port where the other had been. I tried what you suggested about putting a 393 in port 10 and a 269 in port 1 and they both stuttered. Does this mean that I just need to replace the batteries in the pack?