Issues with Cortex and High Strength Motors

Our team is having issues with the new 393 motors. The motors will only travel in one direction and if the joystick position is at zero or the negative full value, it will stop moving all together. I’m just guessing it’s not supposed to work like this and should be continuous rotation in both directions instead of just one. It happens whenever the 393’s are in 2-wire ports 1 and 10. When we add the motor controller 29, we have no issues. It would be really awesome if we could use all of our motor ports instead of just ten.

We have tried using our preferred RobotC using each update that has been put out as well as EasyC for Cortex trial. No luck in either case. We’ve downloaded the cortex firmware following every different method we found all to no avail, so we’re assuming that it doesn’t have to do with the firmware.

Hopefully someone has an idea that would at least put us on the right track to being able to use these motors.


did you try plugging them in backwards?
one of our HS motors were acting funky, and when we plugged it in the other way, it worked fine

Try recalibrating the joystick per this

After upgrading the joy stick firmware the joy stick calibration can get messed up.