Issues with downloading software onto robot and controler

When we try to down load any code onto our robot direct or via vex net i comes up with a screen that says not conected. we have it set to vex net and usb cabel down load mode. we went to toe both at worlds and it worked for a meating and then it quit working on us again. also at worlds we had the up date RobotC to the latest version.

I would really like some help on this issue.

This all started after we downloaded the worlds competion software that vex sent out.

We have up dated the firm ware to the latest non beta version in the cortex and controler, do we need to up grade to the beta version?

this is very fustrating when we are trying to get a mecanum drive base working and we CANT DOWNLOAD ANY PROGRAMS.

Any help is much appreciated,
Thanks if you give any help and if ok if you have no idea what i just said in this post.


Since no one else has answered I guess I will jump in here.

First of all, when posting about this type of problem it’s really important to give us all the information about your setup with the version numbers, for example.

I’m trying to download from Windows XP Service pack 3.
I’m using ROBOTC Version 3.08 and my ROBOTC firmware is 9.12
my cortex has master firmware version 3.21
my joystick has firmware version 3.21

etc. etc.

The tell us exactly how you are trying to download, are you using the USB cable from the PC to the cortex, are you using the orange serial adapter with the joystick tethered to the cortex or are you using the orange serial adapter with VEXnet keys in both joystick and cortex.

So having said this, it sounds like you have a driver issue.

Give us the above information and choose one method of downloading (USB cable, serial adapter etc) and we can start debugging.

We are using the one that they installed at worlds which is 3.08 i think and using the latest non bata .20 or .21 for cortex and remote firmware we have tried both usb and serial cable
hope this helps you help me.

Well, thats a start.

You should use ROBOTC V3.08 along with master firmware 3.21 in both cortex and joystick.

So lets try and download using the orange, prolific adapter. There are some good instructions here but lets do some basic tests.

First, connect the orange serial adapter to the PC and then open the device manager, you should see the prolific driver as a com port like this.


If you do not then it’s probably time to reload the prolific driver.

Next, start up ROBOTC and check that it can see the com port also, goto the “select communications” dialog and check that the port is in the pulldown list. Leave the setting automatic but just check that the port is available.


Next check that you have the “physical robot” selected, that one always gets me.


If all this is good then try to do a software inspection using the Robot->advanced tools menu and let us know what happens.

I will try this on Wednesday during our meating

My teammate may have given some inaccurate info.

The cortex that we were trying to download to is an MSU extra and is notorious for having download problems (both us and team 1581A have had problems using this cortex for test-bots). I don’t believe that this cortex has had its firmware updated for a while. We have given it back to MSU, and we’ll see if this problem continues with our regular cortex, which has the 3.21 Worlds firmware and doesn’t usually have many download issues.

I believe all of the settings you listed are correct. We’ll get back to you after some more experimentation.